National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2015-6822 Detail

Description

The destroy_buffers function in libavcodec/sanm.c in FFmpeg before 2.7.2 does not properly maintain height and width values in the video context, which allows remote attackers to cause a denial of service (segmentation violation and application crash) or possibly have unspecified other impact via crafted LucasArts Smush video data.

Source:  MITRE      Last Modified:  09/05/2015

Quick Info

CVE Dictionary Entry:
CVE-2015-6822
Original release date:
09/05/2015
Last revised:
12/21/2016
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
7.5 HIGH
Vector:
(AV:N/AC:L/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore:
6.4
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://ffmpeg.org/security.html External Source CONFIRM http://ffmpeg.org/security.html
http://git.videolan.org/?p=ffmpeg.git;a=commit;h=39bbdebb1ed8eb9c9b0cd6db85afde6ba89d86e4 External Source CONFIRM http://git.videolan.org/?p=ffmpeg.git;a=commit;h=39bbdebb1ed8eb9c9b0cd6db85afde6ba89d86e4
http://www.securitytracker.com/id/1033483 External Source SECTRACK 1033483

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:ffmpeg:ffmpeg:*:*:*:*:*:*:*:*    versions up to (including) 2.7.1

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 3 change records found - show changes