National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2016-0736 Detail

Current Description

In Apache HTTP Server versions 2.4.0 to 2.4.23, mod_session_crypto was encrypting its data/cookie using the configured ciphers with possibly either CBC or ECB modes of operation (AES256-CBC by default), hence no selectable or builtin authenticated encryption. This made it vulnerable to padding oracle attacks, particularly with CBC.

Source:  MITRE
Description Last Modified:  07/28/2017
View Analysis Description

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 7.5 HIGH
Vector: AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N (V3 legend)
Impact Score: 3.6
Exploitability Score: 3.9


Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): High
Integrity (I): None
Availability (A): None

CVSS v2.0 Severity and Metrics:

Base Score: 5.0 MEDIUM
Vector: (AV:N/AC:L/Au:N/C:P/I:N/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): None
Availability (A): None
Additional Information:
Allows unauthorized disclosure of information

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://rhn.redhat.com/errata/RHSA-2017-1415.html
http://www.debian.org/security/2017/dsa-3796
http://www.securityfocus.com/bid/95078 Third Party Advisory VDB Entry
http://www.securitytracker.com/id/1037508 Third Party Advisory VDB Entry
https://access.redhat.com/errata/RHSA-2017:0906
https://access.redhat.com/errata/RHSA-2017:1161
https://access.redhat.com/errata/RHSA-2017:1413
https://access.redhat.com/errata/RHSA-2017:1414
https://h20566.www2.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbux03725en_us Third Party Advisory
https://httpd.apache.org/security/vulnerabilities_24.html#CVE-2016-0736 Vendor Advisory
https://security.gentoo.org/glsa/201701-36 Third Party Advisory
https://security.netapp.com/advisory/ntap-20180423-0001/
https://support.apple.com/HT208221
https://www.exploit-db.com/exploits/40961/
https://www.tenable.com/security/tns-2017-04

Technical Details

Vulnerability Type (View All)

Change History

8 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2016-0736
NVD Published Date:
07/27/2017
NVD Last Modified:
04/24/2018