National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2016-1019 Detail

Description

Adobe Flash Player 21.0.0.197 and earlier allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via unspecified vectors, as exploited in the wild in April 2016.

Source:  MITRE
Description Last Modified:  04/07/2016

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 9.8 CRITICAL
Vector: AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H (V3 legend)
Impact Score: 5.9
Exploitability Score: 3.9


Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): High
Integrity (I): High
Availability (A): High

CVSS v2.0 Severity and Metrics:

Base Score: 10.0 HIGH
Vector: (AV:N/AC:L/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Insufficient_Info
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://blogs.adobe.com/psirt/?p=1330 Vendor Advisory
http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00009.html
http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00010.html
http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00012.html
http://lists.opensuse.org/opensuse-security-announce/2016-04/msg00055.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00044.html
http://lists.opensuse.org/opensuse-security-announce/2016-05/msg00045.html
http://rhn.redhat.com/errata/RHSA-2016-0610.html
http://www.securityfocus.com/bid/85856
http://www.securitytracker.com/id/1035491
https://helpx.adobe.com/security/products/flash-player/apsa16-01.html Vendor Advisory
https://helpx.adobe.com/security/products/flash-player/apsb16-10.html Vendor Advisory
https://security.gentoo.org/glsa/201606-08
https://technet.microsoft.com/library/security/ms16-050
https://www.fireeye.com/blog/threat-research/2016/04/cve-2016-1019_a_new.html

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
AND
OR
cpe:2.3:a:adobe:flash_player:19.0.0.185:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:19.0.0.207:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:19.0.0.226:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:19.0.0.245:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:20.0.0.228:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:20.0.0.235:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:20.0.0.286:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:20.0.0.306:*:*:*:*:*:*:*
cpe:2.3:a:adobe:flash_player:*:*:*:*:*:*:*:*    versions up to (including) 21.0.0.97
OR
cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:*
cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*
Configuration 2
AND
OR
cpe:2.3:a:adobe:flash_player:*:*:*:*:*:chrome:*:*    versions up to (including) 21.0.0.97
OR
cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:*
cpe:2.3:o:google:chrome_os:*:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*
cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*
Configuration 3
AND
OR
cpe:2.3:a:adobe:flash_player:*:*:*:*:esr:*:*:*    versions up to (including) 18.0.0.333
OR
cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:*
cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*
Configuration 4
AND
OR
cpe:2.3:o:microsoft:windows_8.1:*:*:*:*:*:*:*:*
OR
cpe:2.3:a:adobe:flash_player:*:*:*:*:*:internet_explorer:*:*    versions up to (including) 21.0.0.97
Configuration 5
AND
OR
cpe:2.3:o:microsoft:windows_10:*:*:*:*:*:*:*:*
OR
cpe:2.3:a:adobe:flash_player:*:*:*:*:*:edge:*:*    versions up to (including) 21.0.0.97
cpe:2.3:a:adobe:flash_player:*:*:*:*:*:internet_explorer:*:*    versions up to (including) 21.0.0.97
Configuration 6
OR
cpe:2.3:a:adobe:flash_player:*:*:*:*:*:*:*:*    versions up to (including) 21.0.0.97
Configuration 7
AND
OR
cpe:2.3:a:adobe:flash_player:*:*:*:*:*:*:*:*    versions up to (including) 11.2.202.577
OR
cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

9 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2016-1019
NVD Published Date:
04/07/2016
NVD Last Modified:
05/29/2017