National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

Vulnerability Change Record for CVE-2016-2785

Change History

Modified Analysis - 6/14/2016 10:32:46 AM

Action Type Old Value New Value
Changed Reference Type
https://puppet.com/security/cve/cve-2016-2785 No Types Assigned
https://puppet.com/security/cve/cve-2016-2785 Advisory
Added CWE
CWE-284
Added CVSS V2
(AV:N/AC:L/Au:N/C:P/I:P/A:P)
Added CVSS V3
AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Added CPE Configuration
Configuration 1
     OR
          *cpe:2.3:a:puppetlabs:puppet:4.4.1:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet:4.4.0:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet:4.3.2:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet:4.3.1:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet:4.3.0:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet:4.2.3:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet:4.2.2:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet:4.2.1:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet:4.2.0:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet:4.1.0:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet:4.0.0:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet:4.0.0:rc3:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet:4.0.0:rc2:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet:4.0.0:rc1:*:*:*:*:*:*
Configuration 2
     OR
          *cpe:2.3:a:puppetlabs:puppet_server:2.3.1:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet_server:2.3.0:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet_server:2.2.0:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet_server:2.1.2:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet_server:2.1.1:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet_server:2.1:*:*:*:*:*:*:*
          *cpe:2.3:a:puppetlabs:puppet_server:2.0:*:*:*:*:*:*:*
Configuration 3
     OR
          *cpe:2.3:a:puppetlabs:puppet_agent:1.4.1:*:*:*:*:*:*:*