National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2016-3982 Detail

Current Description

Off-by-one error in the bmp_rle4_fread function in pngxrbmp.c in OptiPNG before 0.7.6 allows remote attackers to cause a denial of service (out-of-bounds read or write access and crash) or possibly execute arbitrary code via a crafted image file, which triggers a heap-based buffer overflow.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: 8.8 HIGH
Vector:  CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://bugs.fi/media/afl/optipng/2/ Issue Tracking
http://lists.opensuse.org/opensuse-updates/2016-04/msg00061.html Third Party Advisory
http://lists.opensuse.org/opensuse-updates/2016-04/msg00065.html Third Party Advisory
http://www.debian.org/security/2016/dsa-3546 Third Party Advisory
http://www.ubuntu.com/usn/USN-2951-1 Third Party Advisory
https://security.gentoo.org/glsa/201608-01
https://sourceforge.net/p/optipng/bugs/57/ Patch Vendor Advisory

Weakness Enumeration

CWE-ID CWE Name Source
CWE-119 Improper Restriction of Operations within the Bounds of a Memory Buffer NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:o:opensuse:leap:42.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:opensuse:opensuse:13.2:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 2 ( hide )
 cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 3 ( hide )
 cpe:2.3:a:optipng_project:optipng:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
0.7.5

Configuration 4 ( hide )
 cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:canonical:ubuntu_linux:15.10:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

10 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2016-3982
NVD Published Date:
04/13/2016
NVD Last Modified:
10/30/2018