National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2017-12612 Detail

Current Description

In Apache Spark 1.6.0 until 2.1.1, the launcher API performs unsafe deserialization of data received by its socket. This makes applications launched programmatically using the launcher API potentially vulnerable to arbitrary code execution by an attacker with access to any user account on the local machine. It does not affect apps run by spark-submit or spark-shell. The attacker would be able to execute code as the user that ran the Spark application. Users are encouraged to update to version 2.2.0 or later.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: 7.8 HIGH
Vector:  CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://www.securityfocus.com/bid/100823 Third Party Advisory VDB Entry
https://mail-archives.apache.org/mod_mbox/spark-dev/201709.mbox/%3CCAEccTyy-1yYuhdNgkBUg0sr9NeaZSrBKkBePdTNZbxXZNTAR-g%40mail.gmail.com%3E Mailing List Vendor Advisory

Weakness Enumeration

CWE-ID CWE Name Source
CWE-502 Deserialization of Untrusted Data NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:apache:spark:1.6.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:apache:spark:1.6.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:apache:spark:1.6.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:apache:spark:1.6.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:apache:spark:2.0.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:apache:spark:2.0.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:apache:spark:2.0.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:apache:spark:2.1.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:apache:spark:2.1.1:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2017-12612
NVD Published Date:
09/13/2017
NVD Last Modified:
09/26/2017