National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2017-18144 Detail

Current Description

In Android before security patch level 2018-04-05 on Qualcomm Snapdragon Mobile and Snapdragon Wear MSM8909W, SD 210/SD 212/SD 205, SD 450, SD 615/16/SD 415, SD 625, SD 650/52, SD 820, SD 835, SD 845, while processing the retransmission of WPA supplicant command send failures, there is a make after break of the connection to WPA supplicant where the local pointer is not properly updated. If the WPA supplicant command transmission fails, a Use After Free condition will occur.

Source:  MITRE
Description Last Modified:  04/11/2018
View Analysis Description

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 9.8 CRITICAL
Vector: AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H (V3 legend)
Impact Score: 5.9
Exploitability Score: 3.9


Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): High
Integrity (I): High
Availability (A): High

CVSS v2.0 Severity and Metrics:

Base Score: 10.0 HIGH
Vector: (AV:N/AC:L/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Insufficient_Info
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://www.securityfocus.com/bid/103671 Third Party Advisory VDB Entry
https://source.android.com/security/bulletin/2018-04-01 Vendor Advisory

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
AND
OR
cpe:2.3:o:qualcomm:msm8909w_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:qualcomm:msm8909w:-:*:*:*:*:*:*:*
Configuration 2
AND
OR
cpe:2.3:o:qualcomm:sd_210_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:qualcomm:sd_210:-:*:*:*:*:*:*:*
Configuration 3
AND
OR
cpe:2.3:o:qualcomm:sd_212_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:qualcomm:sd_212:-:*:*:*:*:*:*:*
Configuration 4
AND
OR
cpe:2.3:o:qualcomm:sd_205_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:qualcomm:sd_205:-:*:*:*:*:*:*:*
Configuration 5
AND
OR
cpe:2.3:o:qualcomm:sd_450_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:qualcomm:sd_450:-:*:*:*:*:*:*:*
Configuration 6
AND
OR
cpe:2.3:o:qualcomm:sd_615_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:qualcomm:sd_615:-:*:*:*:*:*:*:*
Configuration 7
AND
OR
cpe:2.3:o:qualcomm:sd_616_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:qualcomm:sd_616:-:*:*:*:*:*:*:*
Configuration 8
AND
OR
cpe:2.3:o:qualcomm:sd_415_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:qualcomm:sd_415:-:*:*:*:*:*:*:*
Configuration 9
AND
OR
cpe:2.3:o:qualcomm:sd_625_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:qualcomm:sd_625:-:*:*:*:*:*:*:*
Configuration 10
AND
OR
cpe:2.3:o:qualcomm:sd_650_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:qualcomm:sd_650:-:*:*:*:*:*:*:*
Configuration 11
AND
OR
cpe:2.3:o:qualcomm:sd_652_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:qualcomm:sd_652:-:*:*:*:*:*:*:*
Configuration 12
AND
OR
cpe:2.3:o:qualcomm:sd_820_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:qualcomm:sd_820:-:*:*:*:*:*:*:*
Configuration 13
AND
OR
cpe:2.3:o:qualcomm:sd_835_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:qualcomm:sd_835:-:*:*:*:*:*:*:*
Configuration 14
AND
OR
cpe:2.3:o:qualcomm:sd_845_firmware:-:*:*:*:*:*:*:*
OR
cpe:2.3:h:qualcomm:sd_845:-:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2017-18144
NVD Published Date:
04/11/2018
NVD Last Modified:
05/14/2018