National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2017-3120 Detail

Current Description

Adobe Acrobat Reader 2017.009.20058 and earlier, 2017.008.30051 and earlier, 2015.006.30306 and earlier, and 11.0.20 and earlier has an exploitable use after free vulnerability in the XFA parsing engine when handling certain types of internal instructions. Successful exploitation could lead to arbitrary code execution.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: 8.8 HIGH
Vector:  CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://www.securityfocus.com/bid/100182 Third Party Advisory VDB Entry
http://www.securitytracker.com/id/1039098 Third Party Advisory VDB Entry
https://helpx.adobe.com/security/products/acrobat/apsb17-24.html Patch Vendor Advisory

Weakness Enumeration

CWE-ID CWE Name Source
CWE-416 Use After Free NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:adobe:acrobat:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
From (including)
11.0.0
Up to (excluding)
11.0.21
 cpe:2.3:a:adobe:acrobat_dc:*:*:*:*:classic:*:*:*
     Show Matching CPE(s)
From (including)
15.000.0000
Up to (excluding)
15.006.30355
 cpe:2.3:a:adobe:acrobat_dc:*:*:*:*:classic:*:*:*
     Show Matching CPE(s)
From (including)
17.000.0000
Up to (including)
17.011.30066
 cpe:2.3:a:adobe:acrobat_dc:*:*:*:*:continuous:*:*:*
     Show Matching CPE(s)
From (including)
17.000.0000
Up to (excluding)
17.012.20098
 cpe:2.3:a:adobe:acrobat_reader_dc:*:*:*:*:classic:*:*:*
     Show Matching CPE(s)
From (including)
15.000.0000
Up to (excluding)
15.006.30355
 cpe:2.3:a:adobe:acrobat_reader_dc:*:*:*:*:classic:*:*:*
     Show Matching CPE(s)
From (including)
17.000.0000
Up to (excluding)
17.011.30066
 cpe:2.3:a:adobe:acrobat_reader_dc:*:*:*:*:continuous:*:*:*
     Show Matching CPE(s)
From (including)
17.000.0000
Up to (excluding)
17.012.20098
 cpe:2.3:a:adobe:reader:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
From (including)
11.0.0
Up to (excluding)
11.0.21
Running on/with
 cpe:2.3:o:apple:mac_os_x:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:microsoft:windows:*:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

5 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2017-3120
NVD Published Date:
08/11/2017
NVD Last Modified:
08/21/2019