National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2017-9506 Detail

Current Description

The IconUriServlet of the Atlassian OAuth Plugin from version 1.3.0 before version 1.9.12 and from version 2.0.0 before version 2.0.4 allows remote attackers to access the content of internal network resources and/or perform an XSS attack via Server Side Request Forgery (SSRF).

Source:  MITRE
Description Last Modified:  08/23/2017
View Analysis Description

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 6.1 MEDIUM
Vector: AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N (V3 legend)
Impact Score: 2.7
Exploitability Score: 2.8


Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): Required
Scope (S): Changed
Confidentiality (C): Low
Integrity (I): Low
Availability (A): None

CVSS v2.0 Severity and Metrics:

Base Score: 4.3 MEDIUM
Vector: (AV:N/AC:M/Au:N/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://dontpanic.42.nl/2017/12/there-is-proxy-in-your-atlassian.html
https://ecosystem.atlassian.net/browse/OAUTH-344 Issue Tracking Third Party Advisory
https://medium.com/bugbountywriteup/piercing-the-veil-server-side-request-forgery-to-niprnet-access-171018bca2c3
https://twitter.com/ankit_anubhav/status/973566620676382721
https://twitter.com/Zer0Security/status/983529439433777152

Technical Details

Vulnerability Type (View All)

  • Server-Side Request Forgery (SSRF) (CWE-918)

Vulnerable software and versions Switch to CPE 2.3

Configuration 1
OR
cpe:/a:atlassian:oauth:1.3.0
cpe:/a:atlassian:oauth:1.3.1
cpe:/a:atlassian:oauth:1.3.2
cpe:/a:atlassian:oauth:1.3.3
cpe:/a:atlassian:oauth:1.3.4
cpe:/a:atlassian:oauth:1.3.5
cpe:/a:atlassian:oauth:1.3.6
cpe:/a:atlassian:oauth:1.3.7
cpe:/a:atlassian:oauth:1.3.8
cpe:/a:atlassian:oauth:1.3.9
cpe:/a:atlassian:oauth:1.3.10
cpe:/a:atlassian:oauth:1.4.0
cpe:/a:atlassian:oauth:1.4.0:m1
cpe:/a:atlassian:oauth:1.4.0:m2
cpe:/a:atlassian:oauth:1.4.1
cpe:/a:atlassian:oauth:1.5.0
cpe:/a:atlassian:oauth:1.5.0:m1
cpe:/a:atlassian:oauth:1.5.0:m3
cpe:/a:atlassian:oauth:1.6.0
cpe:/a:atlassian:oauth:1.6.0:m1
cpe:/a:atlassian:oauth:1.6.0:m4
cpe:/a:atlassian:oauth:1.6.1
cpe:/a:atlassian:oauth:1.7.0
cpe:/a:atlassian:oauth:1.8.0
cpe:/a:atlassian:oauth:1.8.0:m1
cpe:/a:atlassian:oauth:1.8.1
cpe:/a:atlassian:oauth:1.8.2
cpe:/a:atlassian:oauth:1.8.3
cpe:/a:atlassian:oauth:1.8.4
cpe:/a:atlassian:oauth:1.8.5
cpe:/a:atlassian:oauth:1.9.0
cpe:/a:atlassian:oauth:1.9.0:m1
cpe:/a:atlassian:oauth:1.9.0:m2
cpe:/a:atlassian:oauth:1.9.1
cpe:/a:atlassian:oauth:1.9.2
cpe:/a:atlassian:oauth:1.9.3
cpe:/a:atlassian:oauth:1.9.4
cpe:/a:atlassian:oauth:1.9.5
cpe:/a:atlassian:oauth:1.9.6
cpe:/a:atlassian:oauth:1.9.7
cpe:/a:atlassian:oauth:1.9.8
cpe:/a:atlassian:oauth:1.9.9
cpe:/a:atlassian:oauth:1.9.10
cpe:/a:atlassian:oauth:1.9.11
cpe:/a:atlassian:oauth:2.0.0
cpe:/a:atlassian:oauth:2.0.1
cpe:/a:atlassian:oauth:2.0.2
cpe:/a:atlassian:oauth:2.0.3

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

4 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2017-9506
NVD Published Date:
08/23/2017
NVD Last Modified:
04/10/2018