National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2018-0291 Detail

Current Description

A vulnerability in the Simple Network Management Protocol (SNMP) input packet processor of Cisco NX-OS Software could allow an authenticated, remote attacker to cause the SNMP application on an affected device to restart unexpectedly. The vulnerability is due to improper validation of SNMP protocol data units (PDUs) in SNMP packets. An attacker could exploit this vulnerability by sending a crafted SNMP packet to an affected device. A successful exploit could allow the attacker to cause the SNMP application to restart multiple times, leading to a system-level restart and a denial of service (DoS) condition. This vulnerability affects Nexus 2000 Series Switches, Nexus 3000 Series Switches, Nexus 3500 Platform Switches, Nexus 3600 Platform Switches, Nexus 5500 Platform Switches, Nexus 5600 Platform Switches, Nexus 6000 Series Switches, Nexus 7000 Series Switches, Nexus 7700 Series Switches, Nexus 9000 Series Switches in standalone NX-OS mode, Nexus 9500 R-Series Line Cards and Fabric Modules, UCS 6100 Series Fabric Interconnects, UCS 6200 Series Fabric Interconnects, UCS 6300 Series Fabric Interconnects. Cisco Bug IDs: CSCuw99630, CSCvg71290, CSCvj67977.

Source:  MITRE
Description Last Modified:  06/20/2018
View Analysis Description

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 6.5 MEDIUM
Vector: AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H (V3 legend)
Impact Score: 3.6
Exploitability Score: 2.8


Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): Low
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): None
Integrity (I): None
Availability (A): High

CVSS v2.0 Severity and Metrics:

Base Score: 6.8 MEDIUM
Vector: (AV:N/AC:L/Au:S/C:N/I:N/A:C) (V2 legend)
Impact Subscore: 6.9
Exploitability Subscore: 8.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): Single
Confidentiality (C): None
Integrity (I): None
Availability (A): Complete
Additional Information:
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://www.securitytracker.com/id/1041169 Third Party Advisory VDB Entry
https://tools.cisco.com/security/center/content/CiscoSecurityAdvisory/cisco-sa-20180620-nxossnmp Vendor Advisory

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions from (including) 6.0 up to (excluding) 7.3\(3\)n1\(1\)
OR
cpe:2.3:h:cisco:nexus_5000:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_5010:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_5020:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_5548p:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_5548up:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_5596t:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_5596up:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_56128p:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_5624q:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_5648q:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_5672up:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_5696q:-:*:*:*:*:*:*:*
Configuration 2
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions from (including) 6.2 up to (excluding) 8.1\(2\)
OR
cpe:2.3:h:cisco:nexus_7000:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_7700:-:*:*:*:*:*:*:*
Configuration 3
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions up to (excluding) 7.0\(3\)i3
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions from (including) 7.0\(3\)i4 up to (excluding) 7.0\(3\)i7\(1\)
OR
cpe:2.3:h:cisco:nexus_92160yc-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_92304qc:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_9236c:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_9272q:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_93108tc-ex:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_93120tx:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_93128tx:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_93180yc-ex:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_9332pq:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_9372px:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_9372tx:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_9396px:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_9396tx:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_9504:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_9508:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_9516:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_n9k-c9508-fm-r:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_n9k-x9636c-r:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_n9k-x9636q-r:-:*:*:*:*:*:*:*
Configuration 4
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions up to (excluding) 7.0\(3\)i3
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions from (including) 7.0\(3\)i4 up to (excluding) 7.0\(3\)i7\(1\)
OR
cpe:2.3:h:cisco:nexus_172tq-xl:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3016:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3048:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3064-32t:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3064-t:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3064-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3100-v:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_31128pq:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3132c-z:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3132q:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3132q-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3132q-xl:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3164q:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3172pq:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3172pq-xl:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3172tq:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3172tq-32t:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3232c:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3264c-e:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3264q:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_34180yc:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3524-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3524-xl:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3548:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3548-x:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3548-xl:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_3636c-r:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_c36180yc-r:-:*:*:*:*:*:*:*
Configuration 5
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions from (including) 6.0 up to (excluding) 7.3\(3\)n1\(1\)
OR
cpe:2.3:h:cisco:nexus_6001p:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:nexus_6001t:-:*:*:*:*:*:*:*
Configuration 6
AND
OR
cpe:2.3:o:cisco:nx-os:7.0:*:*:*:*:*:*:*
OR
cpe:2.3:h:cisco:nexus_9500:-:*:*:*:*:*:*:*
Configuration 7
AND
OR
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions up to (excluding) 2.2
cpe:2.3:o:cisco:nx-os:*:*:*:*:*:*:*:*    versions from (including) 2.5 up to (excluding) 3.2\(2b\)
OR
cpe:2.3:h:cisco:ucs_6120xp:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:ucs_6140xp:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:ucs_6248up:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:ucs_6296up:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:ucs_6324:-:*:*:*:*:*:*:*
cpe:2.3:h:cisco:ucs_6332:-:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2018-0291
NVD Published Date:
06/20/2018
NVD Last Modified:
08/21/2018