National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2018-1080 Detail

Description

Dogtag PKI, through version 10.6.1, has a vulnerability in AAclAuthz.java that, under certain configurations, causes the application of ACL allow and deny rules to be reversed. If a server is configured to process allow rules before deny rules (authz.evaluateOrder=allow,deny), then allow rules will deny access and deny rules will grant access. This may result in an escalation of privileges or have other unintended consequences.

Source:  MITRE
Description Last Modified:  07/02/2018

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
https://access.redhat.com/errata/RHSA-2018:1979
https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2018-1080
https://pagure.io/freeipa/issue/7453
https://review.gerrithub.io/c/dogtagpki/pki/+/404435

Technical Details

Vulnerability Type (View All)

Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2018-1080
NVD Published Date:
07/02/2018
NVD Last Modified:
07/03/2018