National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2018-10888 Detail

Description

A flaw was found in libgit2 before version 0.27.3. A missing check in git_delta_apply function in delta.c file, may lead to an out-of-bound read while reading a binary delta file. An attacker may use this flaw to cause a Denial of Service.

Source:  MITRE
Description Last Modified:  07/10/2018

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
https://bugzilla.redhat.com/show_bug.cgi?id=1598024
https://github.com/libgit2/libgit2/commit/9844d38bed10e9ff17174434b3421b227ae710f3
https://github.com/libgit2/libgit2/releases/tag/v0.27.3

Technical Details

Vulnerability Type (View All)

Quick Info

CVE Dictionary Entry:
CVE-2018-10888
NVD Published Date:
07/10/2018
NVD Last Modified:
07/10/2018