National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2018-5740 Detail

Current Description

"deny-answer-aliases" is a little-used feature intended to help recursive server operators protect end users against DNS rebinding attacks, a potential method of circumventing the security model used by client browsers. However, a defect in this feature makes it easy, when the feature is in use, to experience an assertion failure in name.c. Affects BIND 9.7.0->9.8.8, 9.9.0->9.9.13, 9.10.0->9.10.8, 9.11.0->9.11.4, 9.12.0->9.12.2, 9.13.0->9.13.2.

Source:  MITRE
View Analysis Description

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 7.5 HIGH
Vector: AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H (V3.0 legend)
Impact Score: 3.6
Exploitability Score: 3.9


Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): None
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): None
Integrity (I): None
Availability (A): High

CVSS v2.0 Severity and Metrics:

Base Score: 5.0 MEDIUM
Vector: (AV:N/AC:L/Au:N/C:N/I:N/A:P) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): None
Integrity (I): None
Availability (A): Partial
Additional Information:
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00026.html
http://lists.opensuse.org/opensuse-security-announce/2019-06/msg00027.html
http://www.securityfocus.com/bid/105055 Third Party Advisory VDB Entry
http://www.securitytracker.com/id/1041436 Third Party Advisory VDB Entry
https://access.redhat.com/errata/RHSA-2018:2570 Third Party Advisory
https://access.redhat.com/errata/RHSA-2018:2571 Third Party Advisory
https://kb.isc.org/docs/aa-01639 Vendor Advisory
https://lists.debian.org/debian-lts-announce/2018/08/msg00033.html Third Party Advisory
https://security.gentoo.org/glsa/201903-13 Third Party Advisory
https://security.netapp.com/advisory/ntap-20180926-0003/ Third Party Advisory
https://support.hpe.com/hpsc/doc/public/display?docLocale=en_US&docId=emr_na-hpesbux03927en_us
https://usn.ubuntu.com/3769-1/ Third Party Advisory
https://usn.ubuntu.com/3769-2/ Third Party Advisory

Technical Details

Vulnerability Type (View All)

  • Improper Input Validation (CWE-20)

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
From (including)
9.7.0
Up to (excluding)
9.8.8
 cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
From (including)
9.9.0
Up to (excluding)
9.9.13
 cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
From (including)
9.10.0
Up to (excluding)
9.10.8
 cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
From (including)
9.11.0
Up to (excluding)
9.11.4
 cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
From (including)
9.12.0
Up to (excluding)
9.12.2
 cpe:2.3:a:isc:bind:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
From (including)
9.13.0
Up to (excluding)
9.13.2

Configuration 2 ( hide )
 cpe:2.3:o:redhat:enterprise_linux_desktop:6.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:redhat:enterprise_linux_desktop:7.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:redhat:enterprise_linux_server:6.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:redhat:enterprise_linux_server:7.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:redhat:enterprise_linux_server_aus:7.6:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:redhat:enterprise_linux_server_eus:7.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:redhat:enterprise_linux_server_eus:7.6:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:redhat:enterprise_linux_workstation:6.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:redhat:enterprise_linux_workstation:7.0:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 3 ( hide )
 cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 4 ( hide )
 cpe:2.3:a:netapp:data_ontap_edge:-:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 5 ( hide )
 cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:esm:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*
     Show Matching CPE(s)


Change History

6 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2018-5740
NVD Published Date:
01/16/2019
NVD Last Modified:
06/10/2019