National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2018-6558 Detail

Current Description

The pam_fscrypt module in fscrypt before 0.2.4 may incorrectly restore primary and supplementary group IDs to the values associated with the root user, which allows attackers to gain privileges via a successful login through certain applications that use Linux-PAM (aka pam).

Source:  MITRE
Description Last Modified:  08/23/2018
View Analysis Description

Impact

CVSS v3.0 Severity and Metrics:

Base Score: 6.5 MEDIUM
Vector: AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N (V3 legend)
Impact Score: 3.6
Exploitability Score: 2.8


Attack Vector (AV): Network
Attack Complexity (AC): Low
Privileges Required (PR): Low
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): None
Integrity (I): High
Availability (A): None

CVSS v2.0 Severity and Metrics:

Base Score: 4.9 MEDIUM
Vector: (AV:N/AC:M/Au:S/C:N/I:P/A:P) (V2 legend)
Impact Subscore: 4.9
Exploitability Subscore: 6.8


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): Single
Confidentiality (C): None
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
https://github.com/google/fscrypt/commit/3022c1603d968c22f147b4a2c49c4637dd1be91b Patch Third Party Advisory
https://github.com/google/fscrypt/commit/315f9b042237200174a1fb99427f74027e191d66 Patch Third Party Advisory
https://github.com/google/fscrypt/issues/77 Issue Tracking Third Party Advisory
https://launchpad.net/bugs/1787548 Issue Tracking Patch Third Party Advisory

Technical Details

Vulnerability Type (View All)

  • Permissions, Privileges, and Access Control (CWE-264)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:google:fscrypt:*:*:*:*:*:*:*:*    versions up to (excluding) 0.2.4

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2018-6558
NVD Published Date:
08/23/2018
NVD Last Modified:
10/30/2018