National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2018-8087 Detail

Current Description

Memory leak in the hwsim_new_radio_nl function in drivers/net/wireless/mac80211_hwsim.c in the Linux kernel through 4.15.9 allows local users to cause a denial of service (memory consumption) by triggering an out-of-array error case.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: 5.5 MEDIUM
Vector:  CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=0ddcff49b672239dda94d70d0fcf50317a9f4b51 Patch
http://www.securityfocus.com/bid/103397 Third Party Advisory VDB Entry
https://access.redhat.com/errata/RHSA-2019:2029
https://access.redhat.com/errata/RHSA-2019:2043
https://github.com/torvalds/linux/commit/0ddcff49b672239dda94d70d0fcf50317a9f4b51 Patch
https://usn.ubuntu.com/3676-1/ Third Party Advisory
https://usn.ubuntu.com/3676-2/ Third Party Advisory
https://usn.ubuntu.com/3677-1/ Third Party Advisory
https://usn.ubuntu.com/3677-2/ Third Party Advisory
https://usn.ubuntu.com/3678-1/ Third Party Advisory
https://usn.ubuntu.com/3678-2/ Third Party Advisory
https://usn.ubuntu.com/3678-3/ Third Party Advisory
https://usn.ubuntu.com/3678-4/ Third Party Advisory
https://www.debian.org/security/2018/dsa-4188 Third Party Advisory

Weakness Enumeration

CWE-ID CWE Name Source
CWE-772 Missing Release of Resource after Effective Lifetime NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:o:linux:linux_kernel:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
4.15.9

Configuration 2 ( hide )
 cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 3 ( hide )
 cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:canonical:ubuntu_linux:16.04:*:*:*:lts:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:canonical:ubuntu_linux:17.10:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*
     Show Matching CPE(s)


Change History

9 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2018-8087
NVD Published Date:
03/13/2018
NVD Last Modified:
10/02/2019