National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

Vulnerability Change Record for CVE-2019-0037

Change History

CVE Modified by [Source] - 4/10/2019 5:29:00 PM

Action Type Old Value New Value
Changed Description
In a Dynamic Host Configuration Protocol version 6 (DHCPv6) environment, the jdhcpd daemon may crash and restart upon receipt of certain DHCPv6 solicit messages received from a DHCPv6 client.  By continuously sending the same crafted packet, an attacker can repeatedly crash the jdhcpd process causing a sustained Denial of Service (DoS) to both IPv4 and IPv6 clients.
Affected releases are Juniper Networks Junos OS:
15.1 versions prior to 15.1F6-S12, 15.1R7-S3;
15.1X49 versions prior to 15.1X49-D171, 15.1X49-D180;
15.1X53 versions prior to 15.1X53-D236, 15.1X53-D496;
16.1 versions prior to 16.1R3-S10, 16.1R7-S4;
16.2 versions prior to 16.2R2-S8;
17.1 versions prior to 17.1R2-S10, 17.1R3;
17.2 versions prior to 17.2R1-S8, 17.2R3-S1;
17.3 versions prior to 17.3R3-S3;
17.4 versions prior to 17.4R1-S6, 17.4R2-S3;
18.1 versions prior to 18.1R2-S4, 18.1R3-S2;
18.2 versions prior to 18.2R2;
18.2X75 versions prior to 18.2X75-D30;
18.3 versions prior to 18.3R1-S2.

This issue does not affect Junos OS releases prior to 15.1.
In a Dynamic Host Configuration Protocol version 6 (DHCPv6) environment, the jdhcpd daemon may crash and restart upon receipt of certain DHCPv6 solicit messages received from a DHCPv6 client. By continuously sending the same crafted packet, an attacker can repeatedly crash the jdhcpd process causing a sustained Denial of Service (DoS) to both IPv4 and IPv6 clients. Affected releases are Juniper Networks Junos OS: 15.1 versions prior to 15.1F6-S12, 15.1R7-S3; 15.1X49 versions prior to 15.1X49-D171, 15.1X49-D180; 15.1X53 versions prior to 15.1X53-D236, 15.1X53-D496; 16.1 versions prior to 16.1R3-S10, 16.1R7-S4; 16.2 versions prior to 16.2R2-S8; 17.1 versions prior to 17.1R2-S10, 17.1R3; 17.2 versions prior to 17.2R1-S8, 17.2R3-S1; 17.3 versions prior to 17.3R3-S3; 17.4 versions prior to 17.4R1-S6, 17.4R2-S3; 18.1 versions prior to 18.1R2-S4, 18.1R3-S2; 18.2 versions prior to 18.2R2; 18.2X75 versions prior to 18.2X75-D30; 18.3 versions prior to 18.3R1-S2. This issue does not affect Junos OS releases prior to 15.1.