National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2019-16993 Detail

Current Description

In phpBB before 3.1.7-PL1, includes/acp/acp_bbcodes.php has improper verification of a CSRF token on the BBCode page in the Administration Control Panel. An actual CSRF attack is possible if an attacker also manages to retrieve the session id of a reauthenticated administrator prior to targeting them.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: 8.8 HIGH
Vector:  CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
https://github.com/phpbb/phpbb/commit/18abef716ecf42a35416444f3f84f5459d573789 Patch Third Party Advisory
https://lists.debian.org/debian-lts-announce/2019/09/msg00036.html Mailing List Third Party Advisory
https://lists.debian.org/debian-lts-announce/2019/10/msg00006.html Third Party Advisory
https://www.phpbb.com/community/viewtopic.php?t=2352606 Vendor Advisory
https://www.phpbb.com/support/documents.php?mode=changelog&version=3#v317 Vendor Advisory

Weakness Enumeration

CWE-ID CWE Name Source
CWE-352 Cross-Site Request Forgery (CSRF) NIST  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:phpbb:phpbb:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
3.1.7

Configuration 2 ( hide )
 cpe:2.3:o:debian:debian_linux:8.0:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

4 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2019-16993
NVD Published Date:
09/30/2019
NVD Last Modified:
11/21/2019