National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2019-3929 Detail

Current Description

The Crestron AM-100 firmware 1.6.0.2, Crestron AM-101 firmware 2.7.0.1, Barco wePresent WiPG-1000P firmware 2.3.0.10, Barco wePresent WiPG-1600W before firmware 2.4.1.19, Extron ShareLink 200/250 firmware 2.0.3.4, Teq AV IT WIPS710 firmware 1.1.0.7, SHARP PN-L703WA firmware 1.4.2.3, Optoma WPS-Pro firmware 1.0.0.5, Blackbox HD WPS firmware 1.0.0.5, InFocus LiteShow3 firmware 1.0.16, and InFocus LiteShow4 2.0.0.7 are vulnerable to command injection via the file_transfer.cgi HTTP endpoint. A remote, unauthenticated attacker can use this vulnerability to execute operating system commands as root.

Source:  MITRE
View Analysis Description

Severity



CVSS 3.x Severity and Metrics:

NIST CVSS score
NIST: NVD
Base Score: 9.8 CRITICAL
Vector:  CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://packetstormsecurity.com/files/152715/Barco-AWIND-OEM-Presentation-Platform-Unauthenticated-Remote-Command-Injection.html
http://packetstormsecurity.com/files/155948/Barco-WePresent-file_transfer.cgi-Command-Injection.html
https://www.exploit-db.com/exploits/46786/ Exploit Third Party Advisory VDB Entry
https://www.tenable.com/security/research/tra-2019-20 Exploit Third Party Advisory

Weakness Enumeration

CWE-ID CWE Name Source
CWE-77 Improper Neutralization of Special Elements used in a Command ('Command Injection') NIST  
CWE-79 Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') Tenable Network Security, Inc.  

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:o:crestron:am-100_firmware:1.6.0.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
Running on/with
 cpe:2.3:h:crestron:am-100:-:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 2 ( hide )
 cpe:2.3:o:crestron:am-101_firmware:2.7.0.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
Running on/with
 cpe:2.3:h:crestron:am-101:-:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 3 ( hide )
 cpe:2.3:o:barco:wepresent_wipg-1000p_firmware:2.3.0.10:*:*:*:*:*:*:*
     Show Matching CPE(s)
Running on/with
 cpe:2.3:h:barco:wepresent_wipg-1000p:-:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 4 ( hide )
 cpe:2.3:o:barco:wepresent_wipg-1600w_firmware:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (excluding)
2.4.1.19
Running on/with
 cpe:2.3:h:barco:wepresent_wipg-1600w:-:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 5 ( hide )
 cpe:2.3:o:extron:sharelink_200_firmware:2.0.3.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
Running on/with
 cpe:2.3:h:extron:sharelink_200:-:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 6 ( hide )
 cpe:2.3:o:extron:sharelink_250_firmware:2.0.3.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
Running on/with
 cpe:2.3:h:extron:sharelink_250:-:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 7 ( hide )
 cpe:2.3:o:teqavit:wips710_firmware:1.1.0.7:*:*:*:*:*:*:*
     Show Matching CPE(s)
Running on/with
 cpe:2.3:h:teqavit:wips710:-:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 8 ( hide )
 cpe:2.3:o:sharp:pn-l703wa_firmware:1.4.2.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
Running on/with
 cpe:2.3:h:sharp:pn-l703wa:-:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 9 ( hide )
 cpe:2.3:o:optoma:wps-pro_firmware:1.0.0.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
Running on/with
 cpe:2.3:h:optoma:wps-pro:-:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 10 ( hide )
 cpe:2.3:o:blackbox:hd_wireless_presentation_system_firmware:1.0.0.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
Running on/with
 cpe:2.3:h:blackbox:hd_wireless_presentation_system:-:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 11 ( hide )
 cpe:2.3:o:infocus:liteshow3_firmware:1.0.16:*:*:*:*:*:*:*
     Show Matching CPE(s)
Running on/with
 cpe:2.3:h:infocus:liteshow3:-:*:*:*:*:*:*:*
     Show Matching CPE(s)

Configuration 12 ( hide )
 cpe:2.3:o:infocus:liteshow4_firmware:2.0.0.7:*:*:*:*:*:*:*
     Show Matching CPE(s)
Running on/with
 cpe:2.3:h:infocus:liteshow4:-:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

5 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2019-3929
NVD Published Date:
04/30/2019
NVD Last Modified:
05/03/2019