National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2019-7176 Detail

Current Description

An issue was discovered in GitLab Community and Enterprise Edition 8.x (starting in 8.9), 9.x, 10.x, and 11.x before 11.5.9, 11.6.x before 11.6.7, and 11.7.x before 11.7.2. It has Incorrect Access Control. Guest users are able to add reaction emojis on comments to which they have no visibility.

Source:  MITRE
View Analysis Description

Impact

CVSS v3.1 Severity and Metrics:

Base Score: 3.7 LOW
Vector: AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:L/A:N (V3.1 legend)
Impact Score: 1.4
Exploitability Score: 2.2


Attack Vector (AV): Network
Attack Complexity (AC): High
Privileges Required (PR): None
User Interaction (UI): None
Scope (S): Unchanged
Confidentiality (C): None
Integrity (I): Low
Availability (A): None

CVSS v2.0 Severity and Metrics:

Base Score: 4.3 MEDIUM
Vector: (AV:N/AC:M/Au:N/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
https://about.gitlab.com/2019/01/31/security-release-gitlab-11-dot-7-dot-3-released/ Vendor Advisory
https://gitlab.com/gitlab-org/gitlab-ce/issues/51332 Exploit Vendor Advisory

Technical Details

Vulnerability Type (View All)

  • Incorrect Authorization (CWE-863)

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*
     Show Matching CPE(s)
From (including)
8.9.0
Up to (including)
8.17.8
 cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*
     Show Matching CPE(s)
From (including)
8.9.0
Up to (including)
8.17.8
 cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*
     Show Matching CPE(s)
From (including)
9.0.0
Up to (including)
9.5.10
 cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*
     Show Matching CPE(s)
From (including)
9.0.0
Up to (including)
9.5.10
 cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*
     Show Matching CPE(s)
From (including)
10.0.0
Up to (including)
10.8.6
 cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*
     Show Matching CPE(s)
From (including)
10.0.0
Up to (including)
10.8.6
 cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*
     Show Matching CPE(s)
From (including)
11.0.0
Up to (excluding)
11.5.9
 cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*
     Show Matching CPE(s)
From (including)
11.0.0
Up to (excluding)
11.5.9
 cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*
     Show Matching CPE(s)
From (including)
11.6.0
Up to (excluding)
11.6.7
 cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*
     Show Matching CPE(s)
From (including)
11.6.0
Up to (excluding)
11.6.7
 cpe:2.3:a:gitlab:gitlab:*:*:*:*:community:*:*:*
     Show Matching CPE(s)
From (including)
11.7.0
Up to (excluding)
11.7.2
 cpe:2.3:a:gitlab:gitlab:*:*:*:*:enterprise:*:*:*
     Show Matching CPE(s)
From (including)
11.7.0
Up to (excluding)
11.7.2


Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2019-7176
NVD Published Date:
09/09/2019
NVD Last Modified:
09/10/2019