National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2012-3442 Detail

Description

The (1) django.http.HttpResponseRedirect and (2) django.http.HttpResponsePermanentRedirect classes in Django before 1.3.2 and 1.4.x before 1.4.1 do not validate the scheme of a redirect target, which might allow remote attackers to conduct cross-site scripting (XSS) attacks via a data: URL.

Source:  MITRE      Last Modified:  07/31/2012

Quick Info

CVE Dictionary Entry:
CVE-2012-3442
Original release date:
07/31/2012
Last revised:
04/10/2013
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
4.3 MEDIUM
Vector:
(AV:N/AC:M/Au:N/C:N/I:P/A:N) (legend)
Impact Subscore:
2.9
Exploitability Subscore:
8.6
CVSS Version 2 Metrics:
Access Vector:
Network exploitable - Victim must voluntarily interact with attack mechanism
Access Complexity:
Medium
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://www.debian.org/security/2012/dsa-2529 External Source DEBIAN DSA-2529
http://www.mandriva.com/security/advisories?name=MDVSA-2012:143 External Source MANDRIVA MDVSA-2012:143
http://www.openwall.com/lists/oss-security/2012/07/31/1 External Source MLIST [oss-security] 20120730 CVE Request: Django 1.3.1 and 1.4.0 security issues
http://www.openwall.com/lists/oss-security/2012/07/31/2 External Source MLIST [oss-security] 20120730 Re: CVE Request: Django 1.3.1 and 1.4.0 security issues
http://www.ubuntu.com/usn/USN-1560-1 External Source UBUNTU USN-1560-1
https://www.djangoproject.com/weblog/2012/jul/30/security-releases-issued/ Patch; Vendor Advisory External Source CONFIRM https://www.djangoproject.com/weblog/2012/jul/30/security-releases-issued/

Technical Details

Vulnerability Type (View All)

  • Cross-Site Scripting (XSS) (CWE-79)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:djangoproject:django:0.95:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:0.96:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.0:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.0:alpha1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.0:alpha2:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.0:beta:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.0:beta2:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.0.1:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.0.2:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.1:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.1:alpha1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.1:beta1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.1:rc1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.1.2:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.1.3:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.1.4:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.2:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.2:beta1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.2:rc1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.2-alpha1:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.2.2:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.2.4:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.2.5:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.2.6:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.2.7:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:*    versions up to (including) 1.3
cpe:2.3:a:djangoproject:django:1.3:alpha1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.3:beta1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 2 change records found - show changes