National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2014-0474 Detail

Description

The (1) FilePathField, (2) GenericIPAddressField, and (3) IPAddressField model field classes in Django before 1.4.11, 1.5.x before 1.5.6, 1.6.x before 1.6.3, and 1.7.x before 1.7 beta 2 do not properly perform type conversion, which allows remote attackers to have unspecified impact and vectors, related to "MySQL typecasting."

Source:  MITRE      Last Modified:  04/23/2014

Quick Info

CVE Dictionary Entry:
CVE-2014-0474
Original release date:
04/23/2014
Last revised:
01/06/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
10.0 HIGH
Vector:
(AV:N/AC:L/Au:N/C:C/I:C/A:C) (legend)
Impact Subscore:
10.0
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://lists.opensuse.org/opensuse-updates/2014-09/msg00023.html External Source SUSE openSUSE-SU-2014:1132
http://rhn.redhat.com/errata/RHSA-2014-0456.html External Source REDHAT RHSA-2014:0456
http://rhn.redhat.com/errata/RHSA-2014-0457.html External Source REDHAT RHSA-2014:0457
http://secunia.com/advisories/61281 External Source SECUNIA 61281
http://www.debian.org/security/2014/dsa-2934 External Source DEBIAN DSA-2934
http://www.ubuntu.com/usn/USN-2169-1 External Source UBUNTU USN-2169-1
https://www.djangoproject.com/weblog/2014/apr/21/security/ Vendor Advisory External Source CONFIRM https://www.djangoproject.com/weblog/2014/apr/21/security/

Technical Details

Vulnerability Type (View All)

  • Resource Management Errors (CWE-399)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:o:canonical:ubuntu_linux:10.04:-:lts:*:*:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:12.04:-:lts:*:*:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:12.10:*:*:*:*:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:13.10:*:*:*:*:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*
Configuration 2
OR
cpe:2.3:a:djangoproject:django:1.6:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.1:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.2:*:*:*:*:*:*:*
Configuration 3
OR
cpe:2.3:a:djangoproject:django:1.4:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.1:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.2:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.3:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.4:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.5:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.6:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.7:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.8:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.9:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:*    versions up to (including) 1.4.10
Configuration 4
OR
cpe:2.3:a:djangoproject:django:1.7:alpha1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7:alpha2:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7:beta1:*:*:*:*:*:*
Configuration 5
OR
cpe:2.3:a:djangoproject:django:1.5:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.1:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.2:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.3:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.4:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.5:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 3 change records found - show changes