National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2014-0482 Detail

Description

The contrib.auth.middleware.RemoteUserMiddleware middleware in Django before 1.4.14, 1.5.x before 1.5.9, 1.6.x before 1.6.6, and 1.7 before release candidate 3, when using the contrib.auth.backends.RemoteUserBackend backend, allows remote authenticated users to hijack web sessions via vectors related to the REMOTE_USER header.

Source:  MITRE      Last Modified:  08/26/2014

Quick Info

CVE Dictionary Entry:
CVE-2014-0482
Original release date:
08/26/2014
Last revised:
01/06/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
6.0 MEDIUM
Vector:
(AV:N/AC:M/Au:S/C:P/I:P/A:P) (legend)
Impact Subscore:
6.4
Exploitability Subscore:
6.8
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Medium
Authentication:
Required to exploit
Impact Type:
Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://lists.opensuse.org/opensuse-updates/2014-09/msg00023.html External Source SUSE openSUSE-SU-2014:1132
http://secunia.com/advisories/61276 External Source SECUNIA 61276
http://secunia.com/advisories/61281 External Source SECUNIA 61281
http://www.debian.org/security/2014/dsa-3010 External Source DEBIAN DSA-3010
https://www.djangoproject.com/weblog/2014/aug/20/security/ Vendor Advisory External Source CONFIRM https://www.djangoproject.com/weblog/2014/aug/20/security/

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:o:novell:opensuse:12.3:*:*:*:*:*:*:*
cpe:2.3:o:novell:opensuse:13.1:*:*:*:*:*:*:*
Configuration 2
OR
cpe:2.3:a:djangoproject:django:1.6:-:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6:beta1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6:beta2:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6:beta3:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6:beta4:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.1:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.2:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.3:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.4:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.5:*:*:*:*:*:*:*
Configuration 3
OR
cpe:2.3:a:djangoproject:django:1.4:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.1:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.2:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.4:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.5:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.6:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.7:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.8:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.9:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.10:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.11:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.4.12:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:*    versions up to (including) 1.4.13
Configuration 4
OR
cpe:2.3:a:djangoproject:django:1.7:beta1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7:beta2:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7:beta3:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7:beta4:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7:rc1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7:rc2:*:*:*:*:*:*
Configuration 5
OR
cpe:2.3:a:djangoproject:django:1.5:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5:alpha:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5:beta:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.1:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.2:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.3:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.4:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.5:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.6:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.7:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.8:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 4 change records found - show changes