National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2015-2317 Detail

Description

The utils.http.is_safe_url function in Django before 1.4.20, 1.5.x, 1.6.x before 1.6.11, 1.7.x before 1.7.7, and 1.8.x before 1.8c1 does not properly validate URLs, which allows remote attackers to conduct cross-site scripting (XSS) attacks via a control character in a URL, as demonstrated by a \x08javascript: URL.

Source:  MITRE      Last Modified:  03/25/2015

Quick Info

CVE Dictionary Entry:
CVE-2015-2317
Original release date:
03/25/2015
Last revised:
12/21/2016
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
4.3 MEDIUM
Vector:
(AV:N/AC:M/Au:N/C:N/I:P/A:N) (legend)
Impact Subscore:
2.9
Exploitability Subscore:
8.6
CVSS Version 2 Metrics:
Access Vector:
Network exploitable - Victim must voluntarily interact with attack mechanism
Access Complexity:
Medium
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://lists.fedoraproject.org/pipermail/package-announce/2015-April/155421.html Third Party Advisory External Source FEDORA FEDORA-2015-5766
http://lists.fedoraproject.org/pipermail/package-announce/2015-June/160263.html External Source FEDORA FEDORA-2015-9604
http://lists.opensuse.org/opensuse-updates/2015-04/msg00001.html Third Party Advisory External Source SUSE openSUSE-SU-2015:0643
http://lists.opensuse.org/opensuse-updates/2015-09/msg00035.html External Source SUSE openSUSE-SU-2015:1598
http://ubuntu.com/usn/usn-2539-1 Third Party Advisory External Source UBUNTU USN-2539-1
http://www.debian.org/security/2015/dsa-3204 Third Party Advisory External Source DEBIAN DSA-3204
http://www.oracle.com/technetwork/topics/security/bulletinapr2015-2511959.html Third Party Advisory External Source CONFIRM http://www.oracle.com/technetwork/topics/security/bulletinapr2015-2511959.html
http://www.securityfocus.com/bid/73319 External Source BID 73319
https://www.djangoproject.com/weblog/2015/mar/18/security-releases/ Vendor Advisory External Source CONFIRM https://www.djangoproject.com/weblog/2015/mar/18/security-releases/

Technical Details

Vulnerability Type (View All)

  • Cross-Site Scripting (XSS) (CWE-79)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:o:debian:debian_linux:7.0:*:*:*:*:*:*:*
cpe:2.3:o:fedoraproject:fedora:22:*:*:*:*:*:*:*
cpe:2.3:o:novell:opensuse:13.2:*:*:*:*:*:*:*
Configuration 2
OR
cpe:2.3:a:djangoproject:django:*:*:*:*:*:*:*:*    versions up to (including) 1.4.19
cpe:2.3:a:djangoproject:django:1.5:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5:alpha:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5:beta:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.1:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.2:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.3:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.4:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.5:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.6:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.7:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.8:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.9:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.10:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.11:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.5.12:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6:-:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6:beta1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6:beta2:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6:beta3:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6:beta4:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.1:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.2:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.3:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.4:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.5:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.6:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.7:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.8:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.9:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.6.10:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7:beta1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7:beta2:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7:beta3:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7:beta4:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7:rc1:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7:rc2:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7:rc3:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7.1:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7.2:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7.3:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7.4:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7.5:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.7.6:*:*:*:*:*:*:*
cpe:2.3:a:djangoproject:django:1.8.0:*:*:*:*:*:*:*
Configuration 3
OR
cpe:2.3:o:oracle:solaris:11.2:*:*:*:*:*:*:*
Configuration 4
OR
cpe:2.3:o:canonical:ubuntu_linux:10.04:*:*:*:lts:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:12.04:*:*:*:lts:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:14.04:*:*:*:lts:*:*:*
cpe:2.3:o:canonical:ubuntu_linux:14.10:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 11 change records found - show changes