Search Results (Refine Search)

Search Parameters:
  • CPE Product Version: cpe:/a:apple:safari:46::~~technology_preview~~~
There are 1 matching records.
Displaying matches 1 through 1.
Vuln ID Summary CVSS Severity
CVE-2017-17821

WTF/wtf/FastBitVector.h in WebKit, as distributed in Safari Technology Preview Release 46, allows remote attackers to cause a denial of service (buffer overflow) or possibly have unspecified other impact because it calls the FastBitVectorWordOwner::resizeSlow function (in WTF/wtf/FastBitVector.cpp) for a purpose other than initializing a bitvector size, and resizeSlow mishandles cases where the old array length is greater than the new array length.

Published: December 20, 2017; 10:29:00 PM -0500
V3.0: 9.8 CRITICAL
V2.0: 7.5 HIGH