National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

Search Results (Refine Search)

Search Parameters:
  • Contains Software Flaws (CVE)
  • CPE Product Version: cpe:/a:imagemagick:imagemagick:6.2.1
There are 163 matching records.
Displaying matches 161 through 163.
Vuln ID Summary CVSS Severity
CVE-2006-4144

Integer overflow in the ReadSGIImage function in sgi.c in ImageMagick before 6.2.9 allows user-assisted attackers to cause a denial of service (crash) and possibly execute arbitrary code via large (1) bytes_per_pixel, (2) columns, and (3) rows values, which trigger a heap-based buffer overflow.

Published: August 15, 2006; 07:04:00 PM -04:00
    V2: 2.6 LOW
CVE-2005-1739

The XWD Decoder in ImageMagick before 6.2.2.3, and GraphicsMagick before 1.1.6-r1, allows remote attackers to cause a denial of service (infinite loop) via an image with a zero color mask.

Published: May 24, 2005; 12:00:00 AM -04:00
    V2: 5.0 MEDIUM
CVE-2005-1275

Heap-based buffer overflow in the ReadPNMImage function in pnm.c for ImageMagick 6.2.1 and earlier allows remote attackers to cause a denial of service (application crash) via a PNM file with a small colors value.

Published: April 25, 2005; 12:00:00 AM -04:00
    V2: 5.0 MEDIUM