National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

Search Results (Refine Search)

Search Parameters:
  • Contains Software Flaws (CVE)
  • CPE Product Version: cpe:/a:pivotx:pivotx:2.2.0:b2
There are 9 matching records.
Vuln ID Summary CVSS Severity
CVE-2015-5458

Session fixation vulnerability in fileupload.php in PivotX before 2.3.11 allows remote attackers to hijack web sessions via the sess parameter.

Published: July 08, 2015; 11:59:11 AM -04:00
V2: 6.8 MEDIUM
CVE-2015-5457

PivotX before 2.3.11 does not validate the new file extension when renaming a file with multiple extensions, which allows remote attackers to execute arbitrary code by uploading a crafted file, as demonstrated by a file named foo.php.php.

Published: July 08, 2015; 11:59:10 AM -04:00
V2: 7.5 HIGH
CVE-2015-5456

Cross-site scripting (XSS) vulnerability in the form method in modules/formclass.php in PivotX before 2.3.11 allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO, related to the "PHP_SELF" variable and form actions.

Published: July 08, 2015; 11:59:08 AM -04:00
V2: 4.3 MEDIUM
CVE-2014-0342

Multiple unrestricted file upload vulnerabilities in fileupload.php in PivotX before 2.3.9 allow remote authenticated users to execute arbitrary PHP code by uploading a file with a (1) .php or (2) .php# extension, and then accessing it via unspecified vectors.

Published: April 15, 2014; 06:55:11 AM -04:00
V2: 7.5 HIGH
CVE-2014-0341

Multiple cross-site scripting (XSS) vulnerabilities in PivotX before 2.3.9 allow remote authenticated users to inject arbitrary web script or HTML via the title field to (1) templates_internal/pages.tpl, (2) templates_internal/home.tpl, or (3) templates_internal/entries.tpl; (4) an event field to objects.php; or the (5) email or (6) nickname field to pages.php, related to templates_internal/users.tpl.

Published: April 15, 2014; 06:55:11 AM -04:00
V2: 3.5 LOW
CVE-2012-2274

Cross-site scripting (XSS) vulnerability in pivotx/ajaxhelper.php in PivotX 2.3.2 and earlier allows remote attackers to inject arbitrary web script or HTML via the file parameter.

Published: August 13, 2012; 07:55:00 PM -04:00
V2: 4.3 MEDIUM
CVE-2011-1035

The password reset in PivotX before 2.2.4 allows remote attackers to modify the passwords of arbitrary users via unspecified vectors.

Published: February 18, 2011; 08:00:03 PM -05:00
V2: 7.5 HIGH
CVE-2011-0773

Cross-site scripting (XSS) vulnerability in pivotx/modules/module_image.php in PivotX before 2.2.3 allows remote attackers to inject arbitrary web script or HTML via the image parameter.

Published: February 03, 2011; 08:00:10 PM -05:00
V2: 4.3 MEDIUM
CVE-2011-0772

Multiple cross-site scripting (XSS) vulnerabilities in PivotX 2.2.0, and possibly other versions before 2.2.2, allow remote attackers to inject arbitrary web script or HTML via the (1) color parameter to includes/blogroll.php or (2) src parameter to includes/timwrapper.php.

Published: February 03, 2011; 08:00:10 PM -05:00
V2: 4.3 MEDIUM