National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

Search Results (Refine Search)

Search Parameters:
  • Contains Software Flaws (CVE)
  • CPE Product Version: cpe:/a:stunnel:stunnel:0.1
There are 3 matching records.
Vuln ID Summary CVSS Severity
CVE-2014-0016

stunnel before 5.00, when using fork threading, does not properly update the state of the OpenSSL pseudo-random number generator (PRNG), which causes subsequent children with the same process ID to use the same entropy pool and allows remote attackers to obtain private keys for EC (ECDSA) or DSA certificates.

Published: March 24, 2014; 12:31:08 PM -04:00
    V2: 4.3 MEDIUM
CVE-2013-1762

stunnel 4.21 through 4.54, when CONNECT protocol negotiation and NTLM authentication are enabled, does not correctly perform integer conversion, which allows remote proxy servers to execute arbitrary code via a crafted request that triggers a buffer overflow.

Published: March 08, 2013; 01:55:01 PM -05:00
    V2: 6.6 MEDIUM
CVE-2008-2400

Unspecified vulnerability in stunnel before 4.23, when running as a service on Windows, allows local users to gain privileges via unknown attack vectors.

Published: May 22, 2008; 09:09:00 AM -04:00
    V2: 7.2 HIGH