National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

Search Results (Refine Search)

Search Parameters:
  • Contains Software Flaws (CVE)
  • CPE Product Version: cpe:/a:yassl:cyassl:2.9.0
There are 2 matching records.
Vuln ID Summary CVSS Severity
CVE-2014-2899

wolfSSL CyaSSL before 2.9.4 allows remote attackers to cause a denial of service (NULL pointer dereference) via (1) a request for the peer certificate when a certificate parsing failure occurs or (2) a client_key_exchange message when the ephemeral key is not found.

Published: April 22, 2014; 10:23:36 AM -04:00
    V2: 5.0 MEDIUM
CVE-2014-2900

wolfSSL CyaSSL before 2.9.4 does not properly validate X.509 certificates with unknown critical extensions, which allows man-in-the-middle attackers to spoof servers via crafted X.509 certificate.

Published: April 22, 2014; 10:23:36 AM -04:00
    V2: 5.8 MEDIUM