National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2002-1337 Detail

Description

Buffer overflow in Sendmail 5.79 to 8.12.7 allows remote attackers to execute arbitrary code via certain formatted address fields, related to sender and recipient header comments as processed by the crackaddr function of headers.c.

Source:  MITRE
Description Last Modified:  03/07/2003

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 10.0 HIGH
Vector: (AV:N/AC:L/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Provides administrator access
Allows unauthorized disclosure of information
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
ftp://ftp.netbsd.org/pub/NetBSD/security/advisories/NetBSD-SA2003-002.txt.asc
ftp://ftp.sco.com/pub/updates/OpenServer/CSSA-2003-SCO.6
ftp://ftp.sco.com/pub/updates/UnixWare/CSSA-2003-SCO.5
ftp://patches.sgi.com/support/free/security/advisories/20030301-01-P
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000571
http://frontal2.mandriva.com/security/advisories?name=MDKSA-2003:028
http://marc.info/?l=bugtraq&m=104673778105192&w=2
http://marc.info/?l=bugtraq&m=104678739608479&w=2
http://marc.info/?l=bugtraq&m=104678862109841&w=2
http://marc.info/?l=bugtraq&m=104678862409849&w=2
http://marc.info/?l=bugtraq&m=104679411316818&w=2
http://www.cert.org/advisories/CA-2003-07.html Patch Third Party Advisory US Government Resource
http://www.debian.org/security/2003/dsa-257
http://www.iss.net/issEn/delivery/xforce/alertdetail.jsp?oid=21950 Patch Vendor Advisory
http://www.iss.net/security_center/static/10748.php
http://www.kb.cert.org/vuls/id/398025 US Government Resource
http://www.redhat.com/support/errata/RHSA-2003-073.html
http://www.redhat.com/support/errata/RHSA-2003-074.html
http://www.redhat.com/support/errata/RHSA-2003-227.html
http://www.securityfocus.com/bid/6991 Exploit Patch Vendor Advisory
http://www.sendmail.org/8.12.8.html Patch Vendor Advisory
http://www-1.ibm.com/support/search.wss?rs=0&q=IY40500&apar=only
http://www-1.ibm.com/support/search.wss?rs=0&q=IY40501&apar=only
http://www-1.ibm.com/support/search.wss?rs=0&q=IY40502&apar=only
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A2222

References to Check Content

Identifier:
oval:org.mitre.oval:def:2222
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:2222

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:sendmail:advanced_message_server:1.2:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:advanced_message_server:1.3:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:2.6:*:nt:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:2.6.1:*:nt:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:3.0:*:nt:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:3.0.1:*:nt:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:3.0.2:*:nt:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:5.59:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:5.61:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:5.65:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.8.8:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.9.0:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.9.1:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.9.2:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.9.3:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.10:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.10.1:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.10.2:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.11.0:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.11.1:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.11.2:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.11.3:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.11.4:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.11.5:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.11.6:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.12:beta10:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.12:beta12:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.12:beta16:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.12:beta5:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.12:beta7:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.12.0:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.12.1:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.12.2:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.12.3:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.12.4:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.12.5:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.12.6:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail:8.12.7:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail_switch:2.1:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail_switch:2.1.1:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail_switch:2.1.2:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail_switch:2.1.3:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail_switch:2.1.4:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail_switch:2.2:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail_switch:2.2.1:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail_switch:2.2.2:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail_switch:2.2.3:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail_switch:2.2.4:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail_switch:3.0:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail_switch:3.0.1:*:*:*:*:*:*:*
cpe:2.3:a:sendmail:sendmail_switch:3.0.2:*:*:*:*:*:*:*
cpe:2.3:a:sgi:freeware:1.0:*:*:*:*:*:*:*
Configuration 2
OR
cpe:2.3:o:gentoo:linux:1.4:rc1:*:*:*:*:*:*
cpe:2.3:o:gentoo:linux:1.4:rc2:*:*:*:*:*:*
cpe:2.3:o:hp:hp-ux:10.10:*:*:*:*:*:*:*
cpe:2.3:o:hp:hp-ux:10.20:*:*:*:*:*:*:*
cpe:2.3:o:hp:hp-ux:11.00:*:*:*:*:*:*:*
cpe:2.3:o:hp:hp-ux:11.0.4:*:*:*:*:*:*:*
cpe:2.3:o:hp:hp-ux:11.11:*:*:*:*:*:*:*
cpe:2.3:o:hp:hp-ux:11.22:*:*:*:*:*:*:*
cpe:2.3:o:netbsd:netbsd:1.5:*:*:*:*:*:*:*
cpe:2.3:o:netbsd:netbsd:1.5.1:*:*:*:*:*:*:*
cpe:2.3:o:netbsd:netbsd:1.5.2:*:*:*:*:*:*:*
cpe:2.3:o:netbsd:netbsd:1.5.3:*:*:*:*:*:*:*
cpe:2.3:o:netbsd:netbsd:1.6:*:*:*:*:*:*:*
cpe:2.3:o:sun:solaris:2.6:*:*:*:*:*:*:*
cpe:2.3:o:sun:solaris:7.0:*:x86:*:*:*:*:*
cpe:2.3:o:sun:solaris:8.0:*:x86:*:*:*:*:*
cpe:2.3:o:sun:solaris:9.0:*:sparc:*:*:*:*:*
cpe:2.3:o:sun:solaris:9.0:*:x86:*:*:*:*:*
cpe:2.3:o:sun:sunos:-:*:*:*:*:*:*:*
cpe:2.3:o:sun:sunos:5.7:*:*:*:*:*:*:*
cpe:2.3:o:sun:sunos:5.8:*:*:*:*:*:*:*
cpe:2.3:o:windriver:bsdos:4.2:*:*:*:*:*:*:*
cpe:2.3:o:windriver:bsdos:4.3.1:*:*:*:*:*:*:*
cpe:2.3:o:windriver:bsdos:5.0:*:*:*:*:*:*:*
cpe:2.3:o:windriver:platform_sa:1.0:*:*:*:*:*:*:*
Configuration 3
OR
cpe:2.3:h:hp:alphaserver_sc:*:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

6 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2002-1337
NVD Published Date:
03/07/2003
NVD Last Modified:
10/30/2018