National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2004-0415 Detail

Description

Linux kernel does not properly convert 64-bit file offset pointers to 32 bits, which allows local users to access portions of kernel memory.

Source:  MITRE
Description Last Modified:  11/23/2004

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 2.1 LOW
Vector: (AV:L/AC:L/Au:N/C:P/I:N/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 3.9


Access Vector (AV): Local
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): None
Availability (A): None
Additional Information:
Allows unauthorized disclosure of information

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
ftp://patches.sgi.com/support/free/security/advisories/20040804-01-U.asc
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000879
http://www.gentoo.org/security/en/glsa/glsa-200408-24.xml
http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2004:087
http://www.redhat.com/support/errata/RHSA-2004-413.html
http://www.redhat.com/support/errata/RHSA-2004-418.html Patch Vendor Advisory
https://exchange.xforce.ibmcloud.com/vulnerabilities/16877
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9965

References to Check Content

Identifier:
oval:org.mitre.oval:def:9965
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:9965

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.3

Configuration 1
OR
cpe:/o:linux:linux_kernel:2.4.0
cpe:/o:linux:linux_kernel:2.4.0:test1
cpe:/o:linux:linux_kernel:2.4.0:test10
cpe:/o:linux:linux_kernel:2.4.0:test11
cpe:/o:linux:linux_kernel:2.4.0:test12
cpe:/o:linux:linux_kernel:2.4.0:test2
cpe:/o:linux:linux_kernel:2.4.0:test3
cpe:/o:linux:linux_kernel:2.4.0:test4
cpe:/o:linux:linux_kernel:2.4.0:test5
cpe:/o:linux:linux_kernel:2.4.0:test6
cpe:/o:linux:linux_kernel:2.4.0:test7
cpe:/o:linux:linux_kernel:2.4.0:test8
cpe:/o:linux:linux_kernel:2.4.0:test9
cpe:/o:linux:linux_kernel:2.4.1
cpe:/o:linux:linux_kernel:2.4.2
cpe:/o:linux:linux_kernel:2.4.3
cpe:/o:linux:linux_kernel:2.4.4
cpe:/o:linux:linux_kernel:2.4.5
cpe:/o:linux:linux_kernel:2.4.6
cpe:/o:linux:linux_kernel:2.4.7
cpe:/o:linux:linux_kernel:2.4.8
cpe:/o:linux:linux_kernel:2.4.9
cpe:/o:linux:linux_kernel:2.4.10
cpe:/o:linux:linux_kernel:2.4.11
cpe:/o:linux:linux_kernel:2.4.12
cpe:/o:linux:linux_kernel:2.4.13
cpe:/o:linux:linux_kernel:2.4.14
cpe:/o:linux:linux_kernel:2.4.15
cpe:/o:linux:linux_kernel:2.4.16
cpe:/o:linux:linux_kernel:2.4.17
cpe:/o:linux:linux_kernel:2.4.18
cpe:/o:linux:linux_kernel:2.4.18::x86
cpe:/o:linux:linux_kernel:2.4.18:pre1
cpe:/o:linux:linux_kernel:2.4.18:pre2
cpe:/o:linux:linux_kernel:2.4.18:pre3
cpe:/o:linux:linux_kernel:2.4.18:pre4
cpe:/o:linux:linux_kernel:2.4.18:pre5
cpe:/o:linux:linux_kernel:2.4.18:pre6
cpe:/o:linux:linux_kernel:2.4.18:pre7
cpe:/o:linux:linux_kernel:2.4.18:pre8
cpe:/o:linux:linux_kernel:2.4.19
cpe:/o:linux:linux_kernel:2.4.19:pre1
cpe:/o:linux:linux_kernel:2.4.19:pre2
cpe:/o:linux:linux_kernel:2.4.19:pre3
cpe:/o:linux:linux_kernel:2.4.19:pre4
cpe:/o:linux:linux_kernel:2.4.19:pre5
cpe:/o:linux:linux_kernel:2.4.19:pre6
cpe:/o:linux:linux_kernel:2.4.20
cpe:/o:linux:linux_kernel:2.4.21
cpe:/o:linux:linux_kernel:2.4.21:pre1
cpe:/o:linux:linux_kernel:2.4.21:pre4
cpe:/o:linux:linux_kernel:2.4.21:pre7
cpe:/o:linux:linux_kernel:2.4.22
cpe:/o:linux:linux_kernel:2.4.23
cpe:/o:linux:linux_kernel:2.4.23:pre9
cpe:/o:linux:linux_kernel:2.4.23_ow2
cpe:/o:linux:linux_kernel:2.4.24
cpe:/o:linux:linux_kernel:2.4.24_ow1
cpe:/o:linux:linux_kernel:2.4.25
cpe:/o:linux:linux_kernel:2.4.26
cpe:/o:linux:linux_kernel:2.6.0
cpe:/o:linux:linux_kernel:2.6.0:test1
cpe:/o:linux:linux_kernel:2.6.0:test10
cpe:/o:linux:linux_kernel:2.6.0:test11
cpe:/o:linux:linux_kernel:2.6.0:test2
cpe:/o:linux:linux_kernel:2.6.0:test3
cpe:/o:linux:linux_kernel:2.6.0:test4
cpe:/o:linux:linux_kernel:2.6.0:test5
cpe:/o:linux:linux_kernel:2.6.0:test6
cpe:/o:linux:linux_kernel:2.6.0:test7
cpe:/o:linux:linux_kernel:2.6.0:test8
cpe:/o:linux:linux_kernel:2.6.0:test9
cpe:/o:linux:linux_kernel:2.6.1
cpe:/o:linux:linux_kernel:2.6.1:rc1
cpe:/o:linux:linux_kernel:2.6.1:rc2
cpe:/o:linux:linux_kernel:2.6.2
cpe:/o:linux:linux_kernel:2.6.3
cpe:/o:linux:linux_kernel:2.6.4
cpe:/o:linux:linux_kernel:2.6.5
cpe:/o:linux:linux_kernel:2.6.6
cpe:/o:linux:linux_kernel:2.6.6:rc1
cpe:/o:linux:linux_kernel:2.6.7
cpe:/o:linux:linux_kernel:2.6.7:rc1
cpe:/o:linux:linux_kernel:2.6_test9_cvs
cpe:/o:redhat:fedora_core:core_1.0
cpe:/o:trustix:secure_linux:2.0
cpe:/o:trustix:secure_linux:2.1

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2004-0415
NVD Published Date:
11/23/2004
NVD Last Modified:
10/10/2017