National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2004-0500 Detail

Description

Buffer overflow in the MSN protocol plugins (1) object.c and (2) slp.c for Gaim before 0.82 allows remote attackers to cause a denial of service and possibly execute arbitrary code via MSNSLP protocol messages that are not properly handled in a strncpy call.

Source:  MITRE      Last Modified:  09/28/2004

Quick Info

CVE Dictionary Entry:
CVE-2004-0500
Original release date:
09/28/2004
Last revised:
10/10/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
7.5 HIGH
Vector:
(AV:N/AC:L/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore:
6.4
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Provides unauthorized access, Allows partial confidentiality, integrity, and availability violation; Allows unauthorized disclosure of information; Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://gaim.sourceforge.net/security/?id=0 External Source CONFIRM http://gaim.sourceforge.net/security/?id=0
http://www.fedoranews.org/updates/FEDORA-2004-278.shtml External Source FEDORA FEDORA-2004-278
http://www.fedoranews.org/updates/FEDORA-2004-279.shtml External Source FEDORA FEDORA-2004-279
http://www.gentoo.org/security/en/glsa/glsa-200408-12.xml Patch; Vendor Advisory External Source GENTOO GLSA-200408-12
http://www.gentoo.org/security/en/glsa/glsa-200408-27.xml External Source GENTOO GLSA-200408-27
http://www.mandrakesecure.net/en/advisories/advisory.php?name=MDKSA-2004:081 External Source MANDRAKE MDKSA-2004:081
http://www.novell.com/linux/security/advisories/2004_25_gaim.html External Source SUSE SUSE-SA:2004:025
http://www.redhat.com/support/errata/RHSA-2004-400.html External Source REDHAT RHSA-2004:400
http://www.securityfocus.com/bid/10865 Patch; Vendor Advisory External Source BID 10865
https://exchange.xforce.ibmcloud.com/vulnerabilities/16920 External Source XF gaim-msn-bo(16920)
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9429 External Source OVAL oval:org.mitre.oval:def:9429

References to Check Content

Identifier:
oval:org.mitre.oval:def:9429
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:9429

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:rob_flynn:gaim:0.10:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.10.3:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.50:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.51:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.52:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.53:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.54:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.55:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.56:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.57:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.58:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.59:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.59.1:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.60:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.61:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.62:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.63:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.64:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.65:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.66:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.67:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.68:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.69:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.70:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.71:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.72:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.73:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.74:*:*:*:*:*:*:*
cpe:2.3:a:rob_flynn:gaim:0.75:*:*:*:*:*:*:*
Configuration 2
OR
cpe:2.3:o:gentoo:linux:1.4:*:*:*:*:*:*:*
cpe:2.3:o:mandrakesoft:mandrake_linux:9.2:*:*:*:*:*:*:*
cpe:2.3:o:mandrakesoft:mandrake_linux:9.2:*:amd64:*:*:*:*:*
cpe:2.3:o:mandrakesoft:mandrake_linux:10.0:*:*:*:*:*:*:*
cpe:2.3:o:mandrakesoft:mandrake_linux:10.0:*:amd64:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 4 change records found - show changes