National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2005-0004 Detail

Current Description

The mysqlaccess script in MySQL 4.0.23 and earlier, 4.1.x before 4.1.10, 5.0.x before 5.0.3, and other versions including 3.x, allows local users to overwrite arbitrary files or read temporary files via a symlink attack on temporary files.

Source:  MITRE
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 4.6 MEDIUM
Vector: (AV:L/AC:L/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 3.9


Access Vector (AV): Local
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Provides user account access
Allows unauthorized disclosure of information
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://distro.conectiva.com.br/atualizacoes/?id=a&anuncio=000947
http://lists.mysql.com/internals/20600
http://marc.info/?l=bugtraq&m=110608297217224&w=2
http://mysql.osuosl.org/doc/mysql/en/News-4.1.10.html
http://sunsolve.sun.com/search/document.do?assetkey=1-26-101864-1
http://www.debian.org/security/2005/dsa-647 Patch Vendor Advisory
http://www.mandriva.com/security/advisories?name=MDKSA-2005:036
http://www.securityfocus.com/bid/12277 Patch Vendor Advisory
https://exchange.xforce.ibmcloud.com/vulnerabilities/18922

Technical Details

Vulnerability Type (View All)

Known Affected Software Configurations Switch to CPE 2.3

Configuration 1 ( hide )
 cpe:/a:mysql:mysql:4.0.0
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.1
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.2
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.3
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.4
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.5
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.5a
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.6
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.7
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.7:gamma
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.8
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.8:gamma
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.9
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.9:gamma
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.10
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.11
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.11:gamma
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.12
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.13
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.14
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.15
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.18
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.20
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.0.21
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.1.0:alpha
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.1.0.0
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.1.2:alpha
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.1.3
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.1.3:beta
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.1.4
     Show Matching CPE(s)
 cpe:/a:mysql:mysql:4.1.5
     Show Matching CPE(s)

Configuration 2 ( hide )
 cpe:/o:debian:debian_linux:3.0::alpha
     Show Matching CPE(s)
 cpe:/o:debian:debian_linux:3.0::arm
     Show Matching CPE(s)
 cpe:/o:debian:debian_linux:3.0::hppa
     Show Matching CPE(s)
 cpe:/o:debian:debian_linux:3.0::ia-32
     Show Matching CPE(s)
 cpe:/o:debian:debian_linux:3.0::ia-64
     Show Matching CPE(s)
 cpe:/o:debian:debian_linux:3.0::m68k
     Show Matching CPE(s)
 cpe:/o:debian:debian_linux:3.0::mips
     Show Matching CPE(s)
 cpe:/o:debian:debian_linux:3.0::mipsel
     Show Matching CPE(s)
 cpe:/o:debian:debian_linux:3.0::ppc
     Show Matching CPE(s)
 cpe:/o:debian:debian_linux:3.0::s-390
     Show Matching CPE(s)
 cpe:/o:debian:debian_linux:3.0::sparc
     Show Matching CPE(s)
 cpe:/o:gentoo:linux
     Show Matching CPE(s)
 cpe:/o:redhat:fedora_core:core_1.0
     Show Matching CPE(s)
 cpe:/o:redhat:linux:7.3::i386
     Show Matching CPE(s)
 cpe:/o:redhat:linux:9.0::i386
     Show Matching CPE(s)


Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2005-0004
NVD Published Date:
04/14/2005
NVD Last Modified:
07/10/2017