National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2005-3181 Detail

Current Description

The audit system in Linux kernel 2.6.6, and other versions before 2.6.13.4, when CONFIG_AUDITSYSCALL is enabled, uses an incorrect function to free names_cache memory, which prevents the memory from being tracked by AUDITSYSCALL code and leads to a memory leak that allows attackers to cause a denial of service (memory consumption).

Source:  MITRE
Description Last Modified:  10/12/2005
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 2.1 LOW
Vector: (AV:L/AC:L/Au:N/C:N/I:N/A:P) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 3.9


Access Vector (AV): Local
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): None
Integrity (I): None
Availability (A): Partial
Additional Information:
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=829841146878e082613a49581ae252c071057c23
http://linux.bkbits.net:8080/linux-2.6/cset@4346883bQBeBd26syWTKX2CVC5bDcA Vendor Advisory
http://www.debian.org/security/2006/dsa-1017
http://www.mandriva.com/security/advisories?name=MDKSA-2005:218
http://www.mandriva.com/security/advisories?name=MDKSA-2005:219
http://www.mandriva.com/security/advisories?name=MDKSA-2005:220
http://www.mandriva.com/security/advisories?name=MDKSA-2005:235
http://www.redhat.com/support/errata/RHSA-2005-808.html
http://www.securityfocus.com/advisories/9549
http://www.securityfocus.com/advisories/9806
http://www.securityfocus.com/archive/1/427980/100/0/threaded
http://www.securityfocus.com/bid/15076
http://www.ubuntu.com/usn/usn-199-1
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9467

References to Check Content

Identifier:
oval:org.mitre.oval:def:9467
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:9467

Technical Details

Vulnerability Type (View All)

  • Resource Management Errors (CWE-399)

Vulnerable software and versions Switch to CPE 2.3

Configuration 1
OR
cpe:/o:linux:linux_kernel:2.6.0
cpe:/o:linux:linux_kernel:2.6.1
cpe:/o:linux:linux_kernel:2.6.1:rc1
cpe:/o:linux:linux_kernel:2.6.1:rc2
cpe:/o:linux:linux_kernel:2.6.1:rc3
cpe:/o:linux:linux_kernel:2.6.3
cpe:/o:linux:linux_kernel:2.6.3:rc1
cpe:/o:linux:linux_kernel:2.6.3:rc2
cpe:/o:linux:linux_kernel:2.6.3:rc3
cpe:/o:linux:linux_kernel:2.6.3:rc4
cpe:/o:linux:linux_kernel:2.6.4
cpe:/o:linux:linux_kernel:2.6.4:rc1
cpe:/o:linux:linux_kernel:2.6.4:rc2
cpe:/o:linux:linux_kernel:2.6.4:rc3
cpe:/o:linux:linux_kernel:2.6.5
cpe:/o:linux:linux_kernel:2.6.5:rc1
cpe:/o:linux:linux_kernel:2.6.5:rc2
cpe:/o:linux:linux_kernel:2.6.5:rc3
cpe:/o:linux:linux_kernel:2.6.6
cpe:/o:linux:linux_kernel:2.6.6:rc1
cpe:/o:linux:linux_kernel:2.6.6:rc2
cpe:/o:linux:linux_kernel:2.6.6:rc3
cpe:/o:linux:linux_kernel:2.6.7
cpe:/o:linux:linux_kernel:2.6.7:rc1
cpe:/o:linux:linux_kernel:2.6.7:rc2
cpe:/o:linux:linux_kernel:2.6.7:rc3
cpe:/o:linux:linux_kernel:2.6.8
cpe:/o:linux:linux_kernel:2.6.8:rc1
cpe:/o:linux:linux_kernel:2.6.8:rc2
cpe:/o:linux:linux_kernel:2.6.8:rc3
cpe:/o:linux:linux_kernel:2.6.8:rc4
cpe:/o:linux:linux_kernel:2.6.8.1
cpe:/o:linux:linux_kernel:2.6.9
cpe:/o:linux:linux_kernel:2.6.9:rc1
cpe:/o:linux:linux_kernel:2.6.9:rc2
cpe:/o:linux:linux_kernel:2.6.9:rc3
cpe:/o:linux:linux_kernel:2.6.9:rc4
cpe:/o:linux:linux_kernel:2.6.10
cpe:/o:linux:linux_kernel:2.6.10:rc1
cpe:/o:linux:linux_kernel:2.6.10:rc2
cpe:/o:linux:linux_kernel:2.6.10:rc3
cpe:/o:linux:linux_kernel:2.6.11
cpe:/o:linux:linux_kernel:2.6.11:rc1
cpe:/o:linux:linux_kernel:2.6.11:rc2
cpe:/o:linux:linux_kernel:2.6.11:rc3
cpe:/o:linux:linux_kernel:2.6.11:rc4
cpe:/o:linux:linux_kernel:2.6.11:rc5
cpe:/o:linux:linux_kernel:2.6.11.1
cpe:/o:linux:linux_kernel:2.6.11.2
cpe:/o:linux:linux_kernel:2.6.11.3
cpe:/o:linux:linux_kernel:2.6.11.4
cpe:/o:linux:linux_kernel:2.6.11.5
cpe:/o:linux:linux_kernel:2.6.11.6
cpe:/o:linux:linux_kernel:2.6.11.7
cpe:/o:linux:linux_kernel:2.6.11.8
cpe:/o:linux:linux_kernel:2.6.11.9
cpe:/o:linux:linux_kernel:2.6.11.10
cpe:/o:linux:linux_kernel:2.6.11.11
cpe:/o:linux:linux_kernel:2.6.11.12
cpe:/o:linux:linux_kernel:2.6.12
cpe:/o:linux:linux_kernel:2.6.12:rc1
cpe:/o:linux:linux_kernel:2.6.12:rc2
cpe:/o:linux:linux_kernel:2.6.12:rc3
cpe:/o:linux:linux_kernel:2.6.12:rc4
cpe:/o:linux:linux_kernel:2.6.12:rc5
cpe:/o:linux:linux_kernel:2.6.12:rc6
cpe:/o:linux:linux_kernel:2.6.12.1
cpe:/o:linux:linux_kernel:2.6.12.2
cpe:/o:linux:linux_kernel:2.6.12.3
cpe:/o:linux:linux_kernel:2.6.12.4
cpe:/o:linux:linux_kernel:2.6.12.5
cpe:/o:linux:linux_kernel:2.6.12.6
cpe:/o:linux:linux_kernel:2.6.13
cpe:/o:linux:linux_kernel:2.6.13:rc1
cpe:/o:linux:linux_kernel:2.6.13:rc2
cpe:/o:linux:linux_kernel:2.6.13:rc3
cpe:/o:linux:linux_kernel:2.6.13:rc4
cpe:/o:linux:linux_kernel:2.6.13:rc5
cpe:/o:linux:linux_kernel:2.6.13:rc6
cpe:/o:linux:linux_kernel:2.6.13:rc7
cpe:/o:linux:linux_kernel:2.6.13.1
cpe:/o:linux:linux_kernel:2.6.13.2
cpe:/o:linux:linux_kernel    versions up to (including) 2.6.13.3

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

5 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2005-3181
NVD Published Date:
10/12/2005
NVD Last Modified:
10/19/2018