National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2006-0454 Detail

Current Description

Linux kernel before 2.6.15.3 down to 2.6.12, while constructing an ICMP response in icmp_send, does not properly handle when the ip_options_echo function in icmp.c fails, which allows remote attackers to cause a denial of service (crash) via vectors such as (1) record-route and (2) timestamp IP options with the needaddr bit set and a truncated value.

Source:  MITRE      Last Modified:  02/07/2006      View Analysis Description

Quick Info

CVE Dictionary Entry:
CVE-2006-0454
Original release date:
02/07/2006
Last revised:
07/19/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
5.0 MEDIUM
Vector:
(AV:N/AC:L/Au:N/C:N/I:N/A:P) (legend)
Impact Subscore:
2.9
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (09/17/2006)

Not vulnerable. This vulnerability was introduced into the Linux kernel in version 2.6.12 and therefore does not affect users of Red Hat Enterprise Linux 2.1, 3, or 4.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://lists.immunitysec.com/pipermail/dailydave/2006-February/002909.html Patch External Source MLIST [dailydave] 20060207 Fun with Linux (2.6.12 -> 2.6.15.2)
http://marc.info/?l=linux-kernel&m=113927617401569&w=2 External Source MLIST [linux-kernel] 20060207 Linux 2.6.15.3
http://marc.info/?l=linux-kernel&m=113927648820694&w=2 External Source MLIST [linux-kernel] 20060207 Re: Linux 2.6.15.3
http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.15.3 External Source CONFIRM http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.15.3
http://www.mandriva.com/security/advisories?name=MDKSA-2006:040 External Source MANDRIVA MDKSA-2006:040
http://www.novell.com/linux/security/advisories/2006_06_kernel.html Patch; Vendor Advisory External Source SUSE SUSE-SA:2006:006
http://www.redhat.com/archives/fedora-announce-list/2006-February/msg00037.html Patch; Vendor Advisory External Source FEDORA FEDORA-2006-102
http://www.securityfocus.com/archive/1/archive/1/427981/100/0/threaded Patch; Vendor Advisory External Source FEDORA FLSA:157459-4
http://www.securityfocus.com/bid/16532 Patch External Source BID 16532
http://www.trustix.org/errata/2006/0006 Vendor Advisory External Source TRUSTIX 2006-0006
http://www.ubuntu.com/usn/usn-250-1 External Source UBUNTU USN-250-1
http://www.vupen.com/english/advisories/2006/0464 Vendor Advisory External Source VUPEN ADV-2006-0464
https://exchange.xforce.ibmcloud.com/vulnerabilities/24575 External Source XF kernel-icmp-ipoptionsecho-dos(24575)

Technical Details

Vulnerability Type (View All)

  • Resource Management Errors (CWE-399)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:o:linux:linux_kernel:2.6.12:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.12:rc1:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.12:rc2:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.12:rc3:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.12:rc4:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.12:rc5:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.12:rc6:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.12.1:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.12.2:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.12.3:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.12.4:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.12.5:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.12.6:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.13:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.13:rc1:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.13:rc2:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.13:rc3:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.13:rc4:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.13:rc5:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.13:rc6:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.13:rc7:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.13.1:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.13.2:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.13.3:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.13.4:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.13.5:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.14:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.14:rc1:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.14:rc2:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.14:rc3:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.14:rc4:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.14:rc5:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.14.1:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.14.2:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.14.3:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.14.4:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.14.5:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.14.6:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.14.7:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.15:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.15.1:*:*:*:*:*:*:*
cpe:2.3:o:linux:linux_kernel:2.6.15.2:*:*:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 5 change records found - show changes