National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2006-2194 Detail

Description

The winbind plugin in pppd for ppp 2.4.4 and earlier does not check the return code from the setuid function call, which might allow local users to gain privileges by causing setuid to fail, such as exceeding PAM limits for the maximum number of user processes, which prevents the winbind NTLM authentication helper from dropping privileges.

Source:  MITRE
Description Last Modified:  07/05/2006

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 7.2 HIGH
Vector: (AV:L/AC:L/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 3.9


Access Vector (AV): Local
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Provides administrator access
Allows unauthorized disclosure of information
Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (08/16/2006)

Not vulnerable. The winbind plugin is not shipped with Red Hat Enterprise Linux 2.1, 3, or 4.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://www.debian.org/security/2006/dsa-1106 Patch Vendor Advisory
http://www.mandriva.com/security/advisories?name=MDKSA-2006:119
http://www.securityfocus.com/bid/18849 Patch
http://www.ubuntu.com/usn/usn-310-1

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:samba:ppp:*:*:*:*:*:*:*:*    versions up to (including) 2.4.4

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2006-2194
NVD Published Date:
07/05/2006
NVD Last Modified:
04/02/2010