National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2006-4262 Detail

Current Description

Multiple buffer overflows in cscope 15.5 and earlier allow user-assisted attackers to cause a denial of service (crash) and possibly execute arbitrary code via multiple vectors including (1) a long pathname that is not properly handled during file list parsing, (2) long pathnames that result from path variable expansion such as tilde expansion for the HOME environment variable, and (3) a long -f (aka reffile) command line argument.

Source:  MITRE      Last Modified:  08/23/2006      View Analysis Description

Quick Info

CVE Dictionary Entry:
CVE-2006-4262
Original release date:
08/23/2006
Last revised:
10/10/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
5.1 MEDIUM
Vector:
(AV:N/AC:H/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore:
6.4
Exploitability Subscore:
4.9
CVSS Version 2 Metrics:
Access Vector:
Network exploitable - Victim must voluntarily interact with attack mechanism
Access Complexity:
High
Authentication:
Not required to exploit
Impact Type:
Provides user account access, Allows partial confidentiality, integrity, and availability violation; Allows unauthorized disclosure of information; Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (06/16/2009)

Red Hat Enterprise Linux 5 was not vulnerable to this issue as it contained a backported patch since its first release. In Red Hat Enterprise Linux 3 and 4, this issue was addressed via: https://rhn.redhat.com/errata/RHSA-2009-1101.html

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://security.gentoo.org/glsa/glsa-200610-08.xml External Source GENTOO GLSA-200610-08
http://sourceforge.net/mailarchive/forum.php?thread_id=30266760&forum_id=33500 External Source CONFIRM http://sourceforge.net/mailarchive/forum.php?thread_id=30266760&forum_id=33500
http://sourceforge.net/mailarchive/forum.php?thread_id=30266761&forum_id=33500 External Source CONFIRM http://sourceforge.net/mailarchive/forum.php?thread_id=30266761&forum_id=33500
http://www.debian.org/security/2006/dsa-1186 External Source DEBIAN DSA-1186
http://www.redhat.com/support/errata/RHSA-2009-1101.html Vendor Advisory External Source REDHAT RHSA-2009:1101
http://www.securityfocus.com/bid/19686 External Source BID 19686
http://www.securityfocus.com/bid/19687 External Source BID 19687
http://www.vupen.com/english/advisories/2006/3374 Vendor Advisory External Source VUPEN ADV-2006-3374
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=203645 Patch; Vendor Advisory External Source CONFIRM https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=203645
https://exchange.xforce.ibmcloud.com/vulnerabilities/28545 External Source XF cscope-cscopelists-bo(28545)
https://exchange.xforce.ibmcloud.com/vulnerabilities/28546 External Source XF cscope-reffile-bo(28546)
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A9661 External Source OVAL oval:org.mitre.oval:def:9661

References to Check Content

Identifier:
oval:org.mitre.oval:def:9661
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:9661

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:cscope:cscope:*:*:*:*:*:*:*:*    versions up to (including) 15.5

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 4 change records found - show changes