National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2007-1375 Detail

Description

Integer overflow in the substr_compare function in PHP 5.2.1 and earlier allows context-dependent attackers to read sensitive memory via a large value in the length argument, a different vulnerability than CVE-2006-1991.

Source:  MITRE      Last Modified:  03/09/2007

Quick Info

CVE Dictionary Entry:
CVE-2007-1375
Original release date:
03/09/2007
Last revised:
10/10/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
5.0 MEDIUM
Vector:
(AV:N/AC:L/Au:N/C:P/I:N/A:N) (legend)
Impact Subscore:
2.9
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized disclosure of information

Vendor Statements (disclaimer)

Official Statement from Red Hat (11/26/2008)

We do not consider this flaw to be a security issue as it is only exploitable by the script author. No trust boundary is crossed. This flaw exists in versions of PHP as shipped in Red Hat Enterprise Linux 5 and Red Hat Application Stack 1. These issue did not affect the versions of PHP as shipped with Red Hat Enterprise Linux 2.1, 3, 4, Stronghold 4.0, or Red Hat Application Stack 2.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://security.gentoo.org/glsa/glsa-200703-21.xml External Source GENTOO GLSA-200703-21
http://us2.php.net/releases/5_2_2.php External Source CONFIRM http://us2.php.net/releases/5_2_2.php
http://www.debian.org/security/2007/dsa-1283 External Source DEBIAN DSA-1283
http://www.mandriva.com/security/advisories?name=MDKSA-2007:187 External Source MANDRIVA MDKSA-2007:187
http://www.novell.com/linux/security/advisories/2007_32_php.html External Source SUSE SUSE-SA:2007:032
http://www.php-security.org/MOPB/MOPB-14-2007.html Exploit; Vendor Advisory External Source MISC http://www.php-security.org/MOPB/MOPB-14-2007.html
http://www.securityfocus.com/bid/22851 External Source BID 22851
http://www.ubuntu.com/usn/usn-455-1 External Source UBUNTU USN-455-1
https://www.exploit-db.com/exploits/3424 External Source EXPLOIT-DB 3424

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.2.1

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 3 change records found - show changes