National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2007-1475 Detail

Description

Multiple buffer overflows in the (1) ibase_connect and (2) ibase_pconnect functions in the interbase extension in PHP 4.4.6 and earlier allow context-dependent attackers to execute arbitrary code via a long argument.

Source:  MITRE
Description Last Modified:  03/16/2007

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 5.4 MEDIUM
Vector: (AV:A/AC:M/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 5.5


Access Vector (AV): Local_Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Provides unauthorized access
Allows unauthorized disclosure of information
Allows disruption of service

Evaluator Impact

Successful exploitation requires that the Interbase extension is installed.

Vendor Statements (disclaimer)

Official Statement from Red Hat (03/26/2007)

Not vulnerable. PHP as shipped with Red Hat Enterprise Linux 2.1, 3, 4, and 5 does not include ibase support.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://retrogod.altervista.org/php_446_ibase_connect_bof.html Exploit
http://securityreason.com/securityalert/2439
http://www.securityfocus.com/archive/1/archive/1/462931/100/0/threaded Exploit
http://www.securityfocus.com/bid/22976
https://exchange.xforce.ibmcloud.com/vulnerabilities/33019
https://www.exploit-db.com/exploits/3488

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 3.0
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 3.0.6
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 3.0.7
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 3.0.8
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 3.0.9
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.0
cpe:2.3:a:php:php:*:beta1:*:*:*:*:*:*    versions up to (including) 4.0
cpe:2.3:a:php:php:*:beta2:*:*:*:*:*:*    versions up to (including) 4.0
cpe:2.3:a:php:php:*:beta3:*:*:*:*:*:*    versions up to (including) 4.0
cpe:2.3:a:php:php:*:beta4:*:*:*:*:*:*    versions up to (including) 4.0
cpe:2.3:a:php:php:*:beta_4_patch1:*:*:*:*:*:*    versions up to (including) 4.0
cpe:2.3:a:php:php:*:rc1:*:*:*:*:*:*    versions up to (including) 4.0
cpe:2.3:a:php:php:*:rc2:*:*:*:*:*:*    versions up to (including) 4.0
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.0.0
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.0.1
cpe:2.3:a:php:php:*:patch1:*:*:*:*:*:*    versions up to (including) 4.0.1
cpe:2.3:a:php:php:*:patch2:*:*:*:*:*:*    versions up to (including) 4.0.1
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.0.2
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.0.3
cpe:2.3:a:php:php:*:patch1:*:*:*:*:*:*    versions up to (including) 4.0.3
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.0.4
cpe:2.3:a:php:php:*:patch1:*:*:*:*:*:*    versions up to (including) 4.0.4
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.0.5
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.0.6
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.0.7
cpe:2.3:a:php:php:*:rc1:*:*:*:*:*:*    versions up to (including) 4.0.7
cpe:2.3:a:php:php:*:rc2:*:*:*:*:*:*    versions up to (including) 4.0.7
cpe:2.3:a:php:php:*:rc3:*:*:*:*:*:*    versions up to (including) 4.0.7
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.1.0
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.1.1
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.1.2
cpe:2.3:a:php:php:*:*:dev:*:*:*:*:*    versions up to (including) 4.2
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.2.0
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.2.1
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.2.2
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.2.3
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.3
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.3.1
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.3.2
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.3.3
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.3.4
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.3.5
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.3.6
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.3.7
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.3.8
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.3.9
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.3.10
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.3.11
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.4.0
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.4.1
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.4.2
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.4.3
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.4.4
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.4.5
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.4.6

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2007-1475
NVD Published Date:
03/16/2007
NVD Last Modified:
10/18/2017