National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2007-1484 Detail

Description

The array_user_key_compare function in PHP 4.4.6 and earlier, and 5.x up to 5.2.1, makes erroneous calls to zval_dtor, which triggers memory corruption and allows local users to bypass safe_mode and execute arbitrary code via a certain unset operation after array_user_key_compare has been called.

Source:  MITRE      Last Modified:  03/16/2007

Quick Info

CVE Dictionary Entry:
CVE-2007-1484
Original release date:
03/16/2007
Last revised:
03/07/2011
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
4.6 MEDIUM
Vector:
(AV:L/AC:L/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore:
6.4
Exploitability Subscore:
3.9
CVSS Version 2 Metrics:
Access Vector:
Locally exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Provides unauthorized access, Allows partial confidentiality, integrity, and availability violation; Allows unauthorized disclosure of information; Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (04/16/2007)

The PHP interpreter does not offer a reliable "sandboxed" security layer (as found in, say, a JVM) in which untrusted scripts can be run; any script run by the PHP interpreter must be trusted with the privileges of the interpreter itself. We therefore do not classify this issue as security-sensitive since no trust boundary is crossed.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://docs.info.apple.com/article.html?artnum=306172 External Source CONFIRM http://docs.info.apple.com/article.html?artnum=306172
http://lists.apple.com/archives/security-announce//2007/Jul/msg00004.html External Source APPLE APPLE-SA-2007-07-31
http://security.gentoo.org/glsa/glsa-200705-19.xml External Source GENTOO GLSA-200705-19
http://us2.php.net/releases/4_4_7.php External Source CONFIRM http://us2.php.net/releases/4_4_7.php
http://us2.php.net/releases/5_2_2.php External Source CONFIRM http://us2.php.net/releases/5_2_2.php
http://www.novell.com/linux/security/advisories/2007_32_php.html External Source SUSE SUSE-SA:2007:032
http://www.php-security.org/MOPB/MOPB-24-2007.html Exploit External Source MISC http://www.php-security.org/MOPB/MOPB-24-2007.html
http://www.securityfocus.com/bid/22990 External Source BID 22990
http://www.securityfocus.com/bid/25159 External Source BID 25159
http://www.ubuntu.com/usn/usn-455-1 External Source UBUNTU USN-455-1
http://www.vupen.com/english/advisories/2007/2732 External Source VUPEN ADV-2007-2732

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 4.4.6
cpe:2.3:a:php:php:*:rc1:*:*:*:*:*:*    versions up to (including) 5.0
cpe:2.3:a:php:php:*:rc2:*:*:*:*:*:*    versions up to (including) 5.0
cpe:2.3:a:php:php:*:rc3:*:*:*:*:*:*    versions up to (including) 5.0
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.0.0
cpe:2.3:a:php:php:*:beta1:*:*:*:*:*:*    versions up to (including) 5.0.0
cpe:2.3:a:php:php:*:beta2:*:*:*:*:*:*    versions up to (including) 5.0.0
cpe:2.3:a:php:php:*:beta3:*:*:*:*:*:*    versions up to (including) 5.0.0
cpe:2.3:a:php:php:*:beta4:*:*:*:*:*:*    versions up to (including) 5.0.0
cpe:2.3:a:php:php:*:rc1:*:*:*:*:*:*    versions up to (including) 5.0.0
cpe:2.3:a:php:php:*:rc2:*:*:*:*:*:*    versions up to (including) 5.0.0
cpe:2.3:a:php:php:*:rc3:*:*:*:*:*:*    versions up to (including) 5.0.0
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.0.1
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.0.2
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.0.3
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.0.4
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.0.5
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.1
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.1.0
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.1.1
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.1.2
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.1.3
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.1.4
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.1.5
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.1.6
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.2.0
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.2.1

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 1 change record found - show changes