National Vulnerability Database

National Vulnerability Database

National Vulnerability

CVE-2007-3372 Detail


The Avahi daemon in Avahi before 0.6.20 allows attackers to cause a denial of service (exit) via empty TXT data over D-Bus, which triggers an assert error.

Source:  MITRE      Last Modified:  06/22/2007

Quick Info

CVE Dictionary Entry:
Original release date:
Last revised:


CVSS Severity (version 2.0):
CVSS v2 Base Score:
2.1 LOW
(AV:L/AC:L/Au:N/C:N/I:N/A:P) (legend)
Impact Subscore:
Exploitability Subscore:
CVSS Version 2 Metrics:
Access Vector:
Locally exploitable
Access Complexity:
Not required to exploit
Impact Type:
Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (01/08/2009)

Not vulnerable. This issue did not affect the versions of avahi as shipped with Red Hat Enterprise Linux 5.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to

Hyperlink Resource Type Source Name External Source CONFIRM Patch External Source CONFIRM External Source DEBIAN DSA-1690 External Source MANDRIVA MDKSA-2007:185 External Source SUSE SUSE-SR:2007:014 External Source BUGTRAQ 20070628 FLEA-2007-0030-1: avahi avahi-glib avahi-sharp External Source BID 24614 External Source SECTRACK 1018706 External Source UBUNTU USN-696-1 External Source VUPEN ADV-2007-2317 External Source XF avahi-assert-dos(35036)

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
cpe:2.3:a:avahi:avahi:*:*:*:*:*:*:*:*    versions up to (including) 0.6.19

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 2 change records found - show changes