National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2007-4659 Detail

Description

The zend_alter_ini_entry function in PHP before 5.2.4 does not properly handle an interruption to the flow of execution triggered by a memory_limit violation, which has unknown impact and attack vectors.

Source:  MITRE      Last Modified:  09/04/2007

Quick Info

CVE Dictionary Entry:
CVE-2007-4659
Original release date:
09/04/2007
Last revised:
07/28/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
7.5 HIGH
Vector:
(AV:N/AC:L/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore:
6.4
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized disclosure of information; Allows unauthorized modification; Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (09/05/2007)

Not vulnerable. These issues did not affect the versions of PHP as shipped with Red Hat Enterprise Linux 2.1, 3, 4, 5 or Red Hat Application Stack v1.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://www.debian.org/security/2008/dsa-1444 External Source DEBIAN DSA-1444
http://www.gentoo.org/security/en/glsa/glsa-200710-02.xml External Source GENTOO GLSA-200710-02
http://www.php.net/ChangeLog-5.php#5.2.4 Patch External Source CONFIRM http://www.php.net/ChangeLog-5.php#5.2.4
http://www.php.net/releases/5_2_4.php External Source CONFIRM http://www.php.net/releases/5_2_4.php
http://www.trustix.org/errata/2007/0026/ External Source TRUSTIX 2007-0026
http://www.vupen.com/english/advisories/2007/3023 External Source VUPEN ADV-2007-3023
https://exchange.xforce.ibmcloud.com/vulnerabilities/36380 External Source XF php-zendalterinientry-unspecified(36380)
https://issues.rpath.com/browse/RPL-1693 External Source CONFIRM https://issues.rpath.com/browse/RPL-1693
https://issues.rpath.com/browse/RPL-1702 External Source CONFIRM https://issues.rpath.com/browse/RPL-1702

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.2.3

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 3 change records found - show changes