National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2007-4825 Detail

Description

Directory traversal vulnerability in PHP 5.2.4 and earlier allows attackers to bypass open_basedir restrictions and possibly execute arbitrary code via a .. (dot dot) in the dl function.

Source:  MITRE      Last Modified:  09/11/2007

Quick Info

CVE Dictionary Entry:
CVE-2007-4825
Original release date:
09/11/2007
Last revised:
07/28/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
7.5 HIGH
Vector:
(AV:N/AC:L/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore:
6.4
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Provides unauthorized access, Allows partial confidentiality, integrity, and availability violation; Allows unauthorized disclosure of information; Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (09/12/2007)

We do not consider this to be a security issue. For more information please see http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=169857#c1 and http://www.php.net/security-note.php

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://lists.opensuse.org/opensuse-security-announce/2008-01/msg00006.html External Source SUSE SUSE-SA:2008:004
http://securityreason.com/securityalert/3119 External Source SREASON 3119
http://www.gentoo.org/security/en/glsa/glsa-200710-02.xml External Source GENTOO GLSA-200710-02
http://www.php.net/ChangeLog-5.php#5.2.5 External Source CONFIRM http://www.php.net/ChangeLog-5.php#5.2.5
http://www.php.net/releases/5_2_5.php External Source CONFIRM http://www.php.net/releases/5_2_5.php
http://www.securityfocus.com/archive/1/archive/1/478985/100/0/threaded Exploit External Source BUGTRAQ 20070910 PHP <=5.2.4 open_basedir bypass & code exec & denial of service
http://www.securityfocus.com/archive/1/archive/1/478988/100/0/threaded Exploit External Source BUGTRAQ 20070910 /* PHP <=5.2.4 open_basedir bypass & code exec & denial of service errata ... working on windows too .. */
http://www.securityfocus.com/archive/1/archive/1/478989/100/0/threaded Exploit External Source BUGTRAQ 20070910 Re: PHP <=5.2.4 open_basedir bypass & code exec & denial of service
https://exchange.xforce.ibmcloud.com/vulnerabilities/36528 External Source XF php-dl-security-bypass(36528)

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.2.3

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 2 change records found - show changes