National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2008-0227 Detail

Description

yaSSL 1.7.5 and earlier, as used in MySQL and possibly other products, allows remote attackers to cause a denial of service (crash) via a Hello packet containing a large size value, which triggers a buffer over-read in the HASHwithTransform::Update function in hash.cpp.

Source:  MITRE      Last Modified:  01/10/2008

Quick Info

CVE Dictionary Entry:
CVE-2008-0227
Original release date:
01/10/2008
Last revised:
08/07/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
7.5 HIGH
Vector:
(AV:N/AC:L/Au:N/C:P/I:P/A:P) (legend)
Impact Subscore:
6.4
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Provides user account access, Allows partial confidentiality, integrity, and availability violation; Allows unauthorized disclosure of information; Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (01/11/2008)

Not vulnerable. This issue did not affect versions of MySQL as shipped with Red Hat Enterprise Linux 2.1, 3, 4, 5, Red Hat Application Stack v1, and v2, as they are not built with yaSSL support.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://bugs.mysql.com/33814 External Source CONFIRM http://bugs.mysql.com/33814
http://dev.mysql.com/doc/refman/5.1/en/news-5-1-23.html External Source CONFIRM http://dev.mysql.com/doc/refman/5.1/en/news-5-1-23.html
http://lists.apple.com/archives/security-announce/2008/Oct/msg00001.html External Source APPLE APPLE-SA-2008-10-09
http://securityreason.com/securityalert/3531 External Source SREASON 3531
http://support.apple.com/kb/HT3216 External Source CONFIRM http://support.apple.com/kb/HT3216
http://www.debian.org/security/2008/dsa-1478 External Source DEBIAN DSA-1478
http://www.mandriva.com/security/advisories?name=MDVSA-2008:150 External Source MANDRIVA MDVSA-2008:150
http://www.securityfocus.com/archive/1/archive/1/485810/100/0/threaded Exploit External Source BUGTRAQ 20080104 Multiple vulnerabilities in yaSSL 1.7.5
http://www.securityfocus.com/bid/27140 Exploit External Source BID 27140
http://www.securityfocus.com/bid/31681 External Source BID 31681
http://www.ubuntu.com/usn/usn-588-1 External Source UBUNTU USN-588-1
http://www.vupen.com/english/advisories/2008/0560/references External Source VUPEN ADV-2008-0560
http://www.vupen.com/english/advisories/2008/2780 External Source VUPEN ADV-2008-2780
https://exchange.xforce.ibmcloud.com/vulnerabilities/39433 External Source XF yassl-hashwithtransformupdate-dos(39433)

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:yassl:yassl:*:*:*:*:*:*:*:*    versions up to (including) 1.7.5

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 2 change records found - show changes