National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2008-1384 Detail

Description

Integer overflow in PHP 5.2.5 and earlier allows context-dependent attackers to cause a denial of service and possibly have unspecified other impact via a printf format parameter with a large width specifier, related to the php_sprintf_appendstring function in formatted_print.c and probably other functions for formatted strings (aka *printf functions).

Source:  MITRE      Last Modified:  03/27/2008

Quick Info

CVE Dictionary Entry:
CVE-2008-1384
Original release date:
03/27/2008
Last revised:
08/07/2017
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
5.0 MEDIUM
Vector:
(AV:N/AC:L/Au:N/C:N/I:N/A:P) (legend)
Impact Subscore:
2.9
Exploitability Subscore:
10.0
CVSS Version 2 Metrics:
Access Vector:
Network exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows disruption of service

Vendor Statements (disclaimer)

Official Statement from Red Hat (03/28/2008)

Red Hat do not consider this to be a security vulnerability: https://bugzilla.redhat.com/show_bug.cgi?id=CVE-2008-1384

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://cvs.php.net/viewvc.cgi/php-src/NEWS?revision=1.2027.2.547.2.1120&view=markup External Source CONFIRM http://cvs.php.net/viewvc.cgi/php-src/NEWS?revision=1.2027.2.547.2.1120&view=markup
http://lists.opensuse.org/opensuse-security-announce/2008-07/msg00001.html External Source SUSE SUSE-SR:2008:014
http://security.gentoo.org/glsa/glsa-200811-05.xml External Source GENTOO GLSA-200811-05
http://securityreason.com/achievement_securityalert/52 Exploit External Source SREASONRES 20080320 PHP 5.2.5 and prior : *printf() functions Integer Overflow
http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0176 External Source CONFIRM http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0176
http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0178 External Source CONFIRM http://wiki.rpath.com/wiki/Advisories:rPSA-2008-0178
http://www.debian.org/security/2008/dsa-1572 External Source DEBIAN DSA-1572
http://www.mandriva.com/security/advisories?name=MDVSA-2009:022 External Source MANDRIVA MDVSA-2009:022
http://www.mandriva.com/security/advisories?name=MDVSA-2009:023 External Source MANDRIVA MDVSA-2009:023
http://www.securityfocus.com/archive/1/archive/1/489962/100/0/threaded Exploit External Source BUGTRAQ 20080321 {securityreason.com}PHP 5 *printf() - Integer Overflow
http://www.securityfocus.com/archive/1/archive/1/492535/100/0/threaded External Source BUGTRAQ 20080523 rPSA-2008-0176-1 php php-cgi php-imap php-mcrypt php-mysql php-mysqli php-pgsql php-soap php-xsl php5 php5-cgi php5-imap php5-mcrypt php5-mysql php5-mysqli php5-pear php5-pgsql php5-soap php5-xsl
http://www.securityfocus.com/archive/1/archive/1/492671/100/0/threaded External Source BUGTRAQ 20080527 rPSA-2008-0178-1 php php-mysql php-pgsql
http://www.securityfocus.com/bid/28392 External Source BID 28392
http://www.ubuntu.com/usn/usn-628-1 External Source UBUNTU USN-628-1
https://exchange.xforce.ibmcloud.com/vulnerabilities/41386 External Source XF php-phpsprintfappendstring-overflow(41386)
https://issues.rpath.com/browse/RPL-2503 External Source CONFIRM https://issues.rpath.com/browse/RPL-2503

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:php:php:*:*:*:*:*:*:*:*    versions up to (including) 5.2.5

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 2 change records found - show changes