National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2008-3432 Detail

Current Description

Heap-based buffer overflow in the mch_expand_wildcards function in os_unix.c in Vim 6.2 and 6.3 allows user-assisted attackers to execute arbitrary code via shell metacharacters in filenames, as demonstrated by the netrw.v3 test case.

Source:  MITRE
View Analysis Description

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 6.8 MEDIUM
Vector: (AV:N/AC:M/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
ftp://ftp.vim.org/pub/vim/patches/6.2.429
ftp://ftp.vim.org/pub/vim/patches/6.3/6.3.059
http://lists.apple.com/archives/security-announce/2008/Oct/msg00001.html Patch Vendor Advisory
http://support.apple.com/kb/HT3216 Vendor Advisory
http://support.avaya.com/elmodocs2/security/ASA-2009-001.htm
http://www.openwall.com/lists/oss-security/2008/07/15/4
http://www.openwall.com/lists/oss-security/2008/08/01/1
http://www.redhat.com/support/errata/RHSA-2008-0617.html
http://www.securityfocus.com/archive/1/502322/100/0/threaded
http://www.securityfocus.com/bid/30648
http://www.securityfocus.com/bid/31681 Patch
http://www.vmware.com/security/advisories/VMSA-2009-0004.html
http://www.vupen.com/english/advisories/2008/2780
http://www.vupen.com/english/advisories/2009/0033
http://www.vupen.com/english/advisories/2009/0904
https://bugzilla.redhat.com/show_bug.cgi?id=455455
https://exchange.xforce.ibmcloud.com/vulnerabilities/44722
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11203
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A5987

Technical Details

Vulnerability Type (View All)

  • Improper Restriction of Operations within the Bounds of a Memory Buffer (CWE-119)

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:vim:vim:6.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:vim:vim:6.3:*:*:*:*:*:*:*
     Show Matching CPE(s)


Change History

4 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2008-3432
NVD Published Date:
10/10/2008
NVD Last Modified:
10/11/2018