National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2008-3895 Detail

Description

LILO 22.6.1 and earlier stores pre-boot authentication passwords in the BIOS Keyboard buffer and does not clear this buffer before and after use, which allows local users to obtain sensitive information by reading the physical memory locations associated with this buffer.

Source:  MITRE      Last Modified:  09/03/2008

Quick Info

CVE Dictionary Entry:
CVE-2008-3895
Original release date:
09/03/2008
Last revised:
01/29/2009
Source:
US-CERT/NIST

Impact

CVSS Severity (version 2.0):
CVSS v2 Base Score:
2.1 LOW
Vector:
(AV:L/AC:L/Au:N/C:P/I:N/A:N) (legend)
Impact Subscore:
2.9
Exploitability Subscore:
3.9
CVSS Version 2 Metrics:
Access Vector:
Locally exploitable
Access Complexity:
Low
Authentication:
Not required to exploit
Impact Type:
Allows unauthorized disclosure of information

Vendor Statements (disclaimer)

Official Statement from Red Hat (01/01/1900)

Red Hat does not consider this to be a security issue. Since these operations can only be executed by root, no trust boundary is crossed as a result of this behaviour.

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource Type Source Name
http://securityreason.com/securityalert/4211 External Source SREASON 4211
http://www.ivizsecurity.com/preboot-patch.html External Source MISC http://www.ivizsecurity.com/preboot-patch.html
http://www.ivizsecurity.com/research/preboot/preboot_whitepaper.pdf Exploit External Source MISC http://www.ivizsecurity.com/research/preboot/preboot_whitepaper.pdf
http://www.securityfocus.com/archive/1/archive/1/495801/100/0/threaded External Source BUGTRAQ 20080825 [IVIZ-08-008] LILO Security Model bypass exploiting wrong BIOS API usage

Technical Details

Vulnerability Type (View All)

  • Information Leak / Disclosure (CWE-200)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:lilo:lilo:0:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:1:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:2:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:3:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:4:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:5:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:6:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:7:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:8:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:9:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:10:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:11:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:12:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:13:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:14:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:15:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:16:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:17:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:18:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:19:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:20:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21-3:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21.4.2:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21.4.3:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21.4.4:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21.5:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21.5.1:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21.6:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21.6.1:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21.7:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21.7.1:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21.7.2:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21.7.3:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21.7.4:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:21.7.5:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.0:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.0.1:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.0.2:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.1:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.2:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.3:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.3.1:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.3.2:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.3.3:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.3.4:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.4:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.4.1:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.5:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.5.1:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.5.2:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.5.3:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.5.3.1:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.5.4:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.5.5:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.5.6:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.5.7:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.5.7.2:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.5.8:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.5.9:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:22.6:*:*:*:*:*:*:*
cpe:2.3:a:lilo:lilo:*:*:*:*:*:*:*:*    versions up to (including) 22.6.1

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History 1 change record found - show changes