National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2008-4106 Detail

Description

WordPress before 2.6.2 does not properly handle MySQL warnings about insertion of username strings that exceed the maximum column width of the user_login column, and does not properly handle space characters when comparing usernames, which allows remote attackers to change an arbitrary user's password to a random value by registering a similar username and then requesting a password reset, related to a "SQL column truncation vulnerability." NOTE: the attacker can discover the random password by also exploiting CVE-2008-4107.

Source:  MITRE
Description Last Modified:  09/18/2008

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 5.1 MEDIUM
Vector: (AV:N/AC:H/Au:N/C:P/I:P/A:P) (V2 legend)
Impact Subscore: 6.4
Exploitability Subscore: 4.9


Access Vector (AV): Network
Access Complexity (AC): High
Authentication (AU): None
Confidentiality (C): Partial
Integrity (I): Partial
Availability (A): Partial
Additional Information:
Provides unauthorized access
Allows unauthorized disclosure of information
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://marc.info/?l=oss-security&m=122152830017099&w=2
http://securityreason.com/securityalert/4272
http://securitytracker.com/id?1020869
http://wordpress.org/development/2008/09/wordpress-262/ Patch
http://www.debian.org/security/2009/dsa-1871
http://www.openwall.com/lists/oss-security/2008/09/11/6
http://www.securityfocus.com/archive/1/496287/100/0/threaded
http://www.securityfocus.com/bid/31068
http://www.sektioneins.de/advisories/SE-2008-05.txt
http://www.suspekt.org/2008/08/18/mysql-and-sql-column-truncation-vulnerabilities/
http://www.vupen.com/english/advisories/2008/2553
https://www.exploit-db.com/exploits/6397
https://www.exploit-db.com/exploits/6421
https://www.redhat.com/archives/fedora-package-announce/2008-September/msg00607.html
https://www.redhat.com/archives/fedora-package-announce/2008-September/msg00629.html

Technical Details

Vulnerability Type (View All)

Known Affected Software Configurations Switch to CPE 2.2

Configuration 1 ( hide )
 cpe:2.3:a:wordpress:wordpress:0.71-gold:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:1.0-platinum:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:1.0.1-miles:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:1.0.2-blakey:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:1.2-delta:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:1.2-mingus:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:1.2.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:1.2.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:1.5-strayhorn:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:1.5.1.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:1.5.1.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:1.5.1.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:1.5.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.0:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.0.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.0.4:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.0.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.0.6:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.0.7:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.0.9:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.0.10:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.0.11:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.1.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.1.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.1.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.2.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.2.2:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.2.3:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.5:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.5.1:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:2.6:*:*:*:*:*:*:*
     Show Matching CPE(s)
 cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*
     Show Matching CPE(s)
Up to (including)
2.6.1


Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2008-4106
NVD Published Date:
09/18/2008
NVD Last Modified:
10/11/2018