National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2008-5189 Detail

Description

CRLF injection vulnerability in Ruby on Rails before 2.0.5 allows remote attackers to inject arbitrary HTTP headers and conduct HTTP response splitting attacks via a crafted URL to the redirect_to function.

Source:  MITRE
Description Last Modified:  11/21/2008

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 5.0 MEDIUM
Vector: (AV:N/AC:L/Au:N/C:N/I:P/A:N) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 10.0


Access Vector (AV): Network
Access Complexity (AC): Low
Authentication (AU): None
Confidentiality (C): None
Integrity (I): Partial
Availability (A): None
Additional Information:
Allows unauthorized modification

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://github.com/rails/rails/commit/7282ed863ca7e6f928bae9162c9a63a98775a19d
http://lists.opensuse.org/opensuse-security-announce/2008-12/msg00002.html
http://weblog.rubyonrails.org/2008/10/19/rails-2-0-5-redirect_to-and-offset-limit-sanitizing Vendor Advisory
http://weblog.rubyonrails.org/2008/10/19/response-splitting-risk
http://www.securityfocus.com/bid/32359 Patch

Technical Details

Vulnerability Type (View All)

  • Cross-Site Request Forgery (CSRF) (CWE-352)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:rubyonrails:ruby_on_rails:0.5.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.5.5:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.5.6:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.5.7:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.6.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.6.5:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.7.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.8.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.8.5:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.9.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.9.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.9.2:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.9.3:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.9.4:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.9.4.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.10.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.10.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.11.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.11.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.12.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.12.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.13.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.13.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.14.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.14.2:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.14.3:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:0.14.4:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.0.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.1.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.1.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.1.2:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.1.3:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.1.4:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.1.5:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.1.6:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.2.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.2.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.2.2:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.2.3:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.2.4:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.2.5:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.2.6:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:1.9.5:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.0.0:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.0.0:rc1:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.0.0:rc2:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.0.1:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:2.0.2:*:*:*:*:*:*:*
cpe:2.3:a:rubyonrails:ruby_on_rails:*:*:*:*:*:*:*:*    versions up to (including) 2.0.4

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

1 change record found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2008-5189
NVD Published Date:
11/21/2008
NVD Last Modified:
07/06/2012