National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2009-0774 Detail

Description

The layout engine in Mozilla Firefox 2 and 3 before 3.0.7, Thunderbird before 2.0.0.21, and SeaMonkey 1.1.15 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via vectors related to gczeal, a different vulnerability than CVE-2009-0773.

Source:  MITRE
Description Last Modified:  03/04/2009

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 9.3 HIGH
Vector: (AV:N/AC:M/Au:N/C:C/I:C/A:C) (V2 legend)
Impact Subscore: 10.0
Exploitability Subscore: 8.6


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): None
Confidentiality (C): Complete
Integrity (I): Complete
Availability (A): Complete
Additional Information:
Victim must voluntarily interact with attack mechanism
Allows unauthorized disclosure of information
Allows unauthorized modification
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://lists.opensuse.org/opensuse-security-announce/2009-03/msg00002.html
http://lists.opensuse.org/opensuse-security-announce/2009-04/msg00009.html
http://slackware.com/security/viewer.php?l=slackware-security&y=2009&m=slackware-security.405420
http://slackware.com/security/viewer.php?l=slackware-security&y=2009&m=slackware-security.433952
http://support.avaya.com/elmodocs2/security/ASA-2009-069.htm
http://support.avaya.com/japple/css/japple?temp.documentID=366362&temp.productID=154235&temp.releaseID=361845&temp.bucketID=126655&PAGE=Document
http://www.debian.org/security/2009/dsa-1751
http://www.debian.org/security/2009/dsa-1830
http://www.mandriva.com/security/advisories?name=MDVSA-2009:075
http://www.mandriva.com/security/advisories?name=MDVSA-2009:083
http://www.mozilla.org/security/announce/2009/mfsa2009-07.html
http://www.redhat.com/support/errata/RHSA-2009-0258.html
http://www.redhat.com/support/errata/RHSA-2009-0315.html
http://www.redhat.com/support/errata/RHSA-2009-0325.html
http://www.securityfocus.com/bid/33990
http://www.securitytracker.com/id?1021795
http://www.vupen.com/english/advisories/2009/0632
https://bugzilla.mozilla.org/show_bug.cgi?id=473709
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A11138
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A5947
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A6057
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A6121
https://oval.cisecurity.org/repository/search/definition/oval%3Aorg.mitre.oval%3Adef%3A6945
https://usn.ubuntu.com/741-1/
https://www.redhat.com/archives/fedora-package-announce/2009-March/msg00769.html
https://www.redhat.com/archives/fedora-package-announce/2009-March/msg00771.html
https://www.redhat.com/archives/fedora-package-announce/2009-March/msg01077.html

References to Check Content

Identifier:
oval:org.mitre.oval:def:11138
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:11138
Identifier:
oval:org.mitre.oval:def:5947
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:5947
Identifier:
oval:org.mitre.oval:def:6057
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:6057
Identifier:
oval:org.mitre.oval:def:6121
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:6121
Identifier:
oval:org.mitre.oval:def:6945
Check System:
http://oval.mitre.org/XMLSchema/oval-definitions-5
Hyperlink:
http://oval.mitre.org/repository/data/DownloadDefinition?id=oval:org.mitre.oval:def:6945

Technical Details

Vulnerability Type (View All)

  • Resource Management Errors (CWE-399)

Vulnerable software and versions Switch to CPE 2.3

Configuration 1
OR
cpe:/a:mozilla:firefox:1.0
cpe:/a:mozilla:firefox:1.0.1
cpe:/a:mozilla:firefox:1.0.2
cpe:/a:mozilla:firefox:1.0.3
cpe:/a:mozilla:firefox:1.0.4
cpe:/a:mozilla:firefox:1.0.5
cpe:/a:mozilla:firefox:1.0.6
cpe:/a:mozilla:firefox:1.0.7
cpe:/a:mozilla:firefox:1.0.8
cpe:/a:mozilla:firefox:1.5
cpe:/a:mozilla:firefox:1.5.0.1
cpe:/a:mozilla:firefox:1.5.0.2
cpe:/a:mozilla:firefox:1.5.0.3
cpe:/a:mozilla:firefox:1.5.0.4
cpe:/a:mozilla:firefox:1.5.0.5
cpe:/a:mozilla:firefox:1.5.0.6
cpe:/a:mozilla:firefox:1.5.0.7
cpe:/a:mozilla:firefox:1.5.0.8
cpe:/a:mozilla:firefox:1.5.0.9
cpe:/a:mozilla:firefox:1.5.0.10
cpe:/a:mozilla:firefox:1.5.0.11
cpe:/a:mozilla:firefox:1.5.0.12
cpe:/a:mozilla:firefox:2.0
cpe:/a:mozilla:firefox:2.0.0.1
cpe:/a:mozilla:firefox:2.0.0.2
cpe:/a:mozilla:firefox:2.0.0.3
cpe:/a:mozilla:firefox:2.0.0.4
cpe:/a:mozilla:firefox:2.0.0.5
cpe:/a:mozilla:firefox:2.0.0.6
cpe:/a:mozilla:firefox:2.0.0.7
cpe:/a:mozilla:firefox:2.0.0.8
cpe:/a:mozilla:firefox:2.0.0.9
cpe:/a:mozilla:firefox:2.0.0.10
cpe:/a:mozilla:firefox:2.0.0.11
cpe:/a:mozilla:firefox:2.0.0.12
cpe:/a:mozilla:firefox:2.0.0.13
cpe:/a:mozilla:firefox:2.0.0.14
cpe:/a:mozilla:firefox:2.0.0.15
cpe:/a:mozilla:firefox:2.0.0.16
cpe:/a:mozilla:firefox:2.0.0.17
cpe:/a:mozilla:firefox:2.0.0.18
cpe:/a:mozilla:firefox:2.0.0.19
cpe:/a:mozilla:firefox:2.0.0.20
cpe:/a:mozilla:firefox:3.0
cpe:/a:mozilla:firefox:3.0.1
cpe:/a:mozilla:firefox:3.0.2
cpe:/a:mozilla:firefox:3.0.3
cpe:/a:mozilla:firefox:3.0.4
cpe:/a:mozilla:firefox:3.0.5
cpe:/a:mozilla:firefox    versions up to (including) 3.0.6
cpe:/a:mozilla:seamonkey:1.0
cpe:/a:mozilla:seamonkey:1.0.1
cpe:/a:mozilla:seamonkey:1.0.2
cpe:/a:mozilla:seamonkey:1.0.3
cpe:/a:mozilla:seamonkey:1.0.5
cpe:/a:mozilla:seamonkey:1.0.6
cpe:/a:mozilla:seamonkey:1.0.7
cpe:/a:mozilla:seamonkey:1.0.8
cpe:/a:mozilla:seamonkey:1.0.9
cpe:/a:mozilla:seamonkey:1.1
cpe:/a:mozilla:seamonkey:1.1:alpha
cpe:/a:mozilla:seamonkey:1.1:beta
cpe:/a:mozilla:seamonkey:1.1.1
cpe:/a:mozilla:seamonkey:1.1.2
cpe:/a:mozilla:seamonkey:1.1.3
cpe:/a:mozilla:seamonkey:1.1.4
cpe:/a:mozilla:seamonkey:1.1.5
cpe:/a:mozilla:seamonkey:1.1.6
cpe:/a:mozilla:seamonkey:1.1.7
cpe:/a:mozilla:seamonkey:1.1.8
cpe:/a:mozilla:seamonkey:1.1.9
cpe:/a:mozilla:seamonkey:1.1.10
cpe:/a:mozilla:seamonkey:1.1.11
cpe:/a:mozilla:seamonkey:1.1.12
cpe:/a:mozilla:seamonkey:1.1.13
cpe:/a:mozilla:seamonkey    versions up to (including) 1.1.14
cpe:/a:mozilla:thunderbird:2.0.0.0
cpe:/a:mozilla:thunderbird:2.0.0.4
cpe:/a:mozilla:thunderbird:2.0.0.5
cpe:/a:mozilla:thunderbird:2.0.0.6
cpe:/a:mozilla:thunderbird:2.0.0.9
cpe:/a:mozilla:thunderbird:2.0.0.12
cpe:/a:mozilla:thunderbird:2.0.0.14
cpe:/a:mozilla:thunderbird:2.0.0.16
cpe:/a:mozilla:thunderbird:2.0.0.17
cpe:/a:mozilla:thunderbird:2.0.0.18
cpe:/a:mozilla:thunderbird:2.0.0.19
cpe:/a:mozilla:thunderbird    versions up to (including) 2.0.0.20

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

3 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2009-0774
NVD Published Date:
03/04/2009
NVD Last Modified:
10/03/2018