National Vulnerability Database

National Vulnerability Database

National Vulnerability
Database

CVE-2009-0871 Detail

Description

The SIP channel driver in Asterisk Open Source 1.4.22, 1.4.23, and 1.4.23.1; 1.6.0 before 1.6.0.6; 1.6.1 before 1.6.1.0-rc2; and Asterisk Business Edition C.2.3, with the pedantic option enabled, allows remote authenticated users to cause a denial of service (crash) via a SIP INVITE request without any headers, which triggers a NULL pointer dereference in the (1) sip_uri_headers_cmp and (2) sip_uri_params_cmp functions.

Source:  MITRE
Description Last Modified:  03/11/2009

Impact

CVSS v2.0 Severity and Metrics:

Base Score: 3.5 LOW
Vector: (AV:N/AC:M/Au:S/C:N/I:N/A:P) (V2 legend)
Impact Subscore: 2.9
Exploitability Subscore: 6.8


Access Vector (AV): Network
Access Complexity (AC): Medium
Authentication (AU): Single
Confidentiality (C): None
Integrity (I): None
Availability (A): Partial
Additional Information:
Allows disruption of service

References to Advisories, Solutions, and Tools

By selecting these links, you will be leaving NIST webspace. We have provided these links to other web sites because they may have information that would be of interest to you. No inferences should be drawn on account of other sites being referenced, or not, from this page. There may be other web sites that are more appropriate for your purpose. NIST does not necessarily endorse the views expressed, or concur with the facts presented on these sites. Further, NIST does not endorse any commercial products that may be mentioned on these sites. Please address comments about this page to nvd@nist.gov.

Hyperlink Resource
http://bugs.digium.com/view.php?id=13547
http://bugs.digium.com/view.php?id=14417
http://downloads.digium.com/pub/security/AST-2009-002.html Patch Vendor Advisory
http://www.securityfocus.com/archive/1/501656/100/0/threaded
http://www.securityfocus.com/bid/34070 Patch
http://www.securitytracker.com/id?1021834
http://www.vupen.com/english/advisories/2009/0667

Technical Details

Vulnerability Type (View All)

Vulnerable software and versions Switch to CPE 2.2

Configuration 1
OR
cpe:2.3:a:digium:asterisk:1.4.22:*:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.4.23:*:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.4.23.1:*:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0:*:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0:beta1:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0:beta2:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0:beta3:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0:beta4:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0:beta5:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0:beta6:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0:beta7:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0:beta7.1:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0:beta8:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0:beta9:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0:rc4:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0:rc5:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0:rc6:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0.1:*:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0.2:*:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0.3:*:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0.3:rc1:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0.4:rc1:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.0.5:*:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.1:*:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.1:beta1:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.1:beta2:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.1:beta3:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.1:beta4:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:1.6.1:rc1:*:*:*:*:*:*
cpe:2.3:a:digium:asterisk:c.2.3:-:business:*:*:*:*:*

Denotes Vulnerable Software
Are we missing a CPE here? Please let us know.

Change History

2 change records found - show changes

Quick Info

CVE Dictionary Entry:
CVE-2009-0871
NVD Published Date:
03/11/2009
NVD Last Modified:
10/10/2018